Bug 11747 - -E option is invalid
-E option is invalid
Status: RESOLVED INVALID
Product: ccache
Classification: Unclassified
Component: ccache
3.2.3
x64 Linux
: P5 normal
: ---
Assigned To: Joel Rosdahl
Joel Rosdahl
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-23 07:27 UTC by Shawn Peng
Modified: 2016-02-24 07:16 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shawn Peng 2016-02-23 07:27:17 UTC
When I call ccache with '-E' option, I got this error:

ccache: invalid option -- 'E'

Is this what meant to be or some catch? Although that I found I can use /usr/lib64/ccache/gcc to do with the '-E' option, but some software compiling might need this, like 'cutorch'.
Comment 1 Shawn Peng 2016-02-23 08:09:41 UTC
I found something. If I rename the ccache to gcc, then there is no problem. So, I think this is not a bug. However, I think this a little not intuitive to me. Maybe there should be another command to take care of those management stuffs. I think this way would be better.
Comment 2 Joel Rosdahl 2016-02-24 07:16:48 UTC
Hi Shawn!

You are correct in that it's not a bug. Please read instructions on how to use ccache here: https://ccache.samba.org/manual.html#_run_modes