Bug 1166 - winbindd crashing in ads_pull_uin32()
winbindd crashing in ads_pull_uin32()
Status: RESOLVED DUPLICATE of bug 1127
Product: Samba 3.0
Classification: Unclassified
Component: winbind
3.0.2a
All Linux
: P4 major
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-10 05:39 UTC by Miguel Angel Rasero Peral
Modified: 2005-11-14 09:26 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Miguel Angel Rasero Peral 2004-03-10 05:39:11 UTC
First sorry if the bugreport it´s not perfect, it is my first samba bug report
and i am not programmer. I have a problem when printing to a samba 3.0.2a-Debian
in my woody install, all works fine but at any random time, usually 24-48 hours
i get this in my logs and the printing go crazy, any times works, other no, any
times i can open the machine in my network places, other no, this show my logs.
log.smbd
[2004/03/10 13:50:08, 2] smbd/server.c:exit_server(558)
  Closing connections
[2004/03/10 14:01:15, 2] smbd/sesssetup.c:setup_new_vc_session(591)
  setup_new_vc_session: New VC == 0, if NT4.x compatible we would close all old
resources.
[2004/03/10 14:01:17, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2004/03/10 14:01:17, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 3350 (3.0.2a-Debian)
  Please read the appendix Bugs of the Samba HOWTO collection
[2004/03/10 14:01:17, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2004/03/10 14:01:17, 0] lib/util.c:smb_panic(1390)
  smb_panic(): calling panic action [/usr/share/samba/panic-action 3350]
[2004/03/10 14:01:17, 0] lib/util.c:smb_panic(1398)
  smb_panic(): action returned status 0
[2004/03/10 14:01:17, 0] lib/util.c:smb_panic(1400)
  PANIC: internal error
[2004/03/10 14:01:17, 0] lib/util.c:smb_panic(1408)
  BACKTRACE: 16 stack frames:
   #0 /usr/sbin/smbd(smb_panic+0x16b) [0x8185483]
   #1 /usr/sbin/smbd [0x81760d3]
   #2 /usr/sbin/smbd [0x8176135]
   #3 /lib/libc.so.6 [0x4017f4a8]
   #4 /usr/sbin/smbd(print_queue_status+0x12b) [0x819e45b]
   #5 /usr/sbin/smbd [0x8089ed7]
   #6 /usr/sbin/smbd(api_reply+0x270) [0x808fa00]
   #7 /usr/sbin/smbd [0x8087827]
   #8 /usr/sbin/smbd(reply_trans+0x94f) [0x80882af]
   #9 /usr/sbin/smbd [0x80ba03a]
   #10 /usr/sbin/smbd [0x80ba0d3]
   #11 /usr/sbin/smbd(process_smb+0x187) [0x80ba373]
   #12 /usr/sbin/smbd(smbd_process+0x14f) [0x80baccf]
   #13 /usr/sbin/smbd(main+0x69b) [0x81ddaff]
   #14 /lib/libc.so.6(__libc_start_main+0xc6) [0x4016bdc6]
   #15 /usr/sbin/smbd(yp_get_default_domain+0x8d) [0x8077261]

This is a member of a ADS with a Windows 2000 server doing the DC,wins and dns
job. i am using winbind to map the usernames. When i reload samba all works
fine. Here do you have the important files.

smb.conf
[global]

# Do something sensible when Samba crashes: mail the admin a backtrace
panic action = /usr/share/samba/panic-action %d

# Change this for the workgroup/NT-domain name your Samba server will part of
workgroup = ASECORD

# server string is the equivalent of the NT Description field
server string = Servidor Impresoras
netbios name = PRINTERS

# If you want to automatically load your printer list rather
# than setting them up individually then you'll need this
load printers = yes

# You may wish to override the location of the printcap file
printcap name = cups

# 'printing = cups' works nicely
printing = cups

;   guest account = nobody
#invalid users = root

# This tells Samba to use a separate log file for each machine
# that connects
log file = /var/log/samba/log.%m

# Put a capping on the size of the log files (in Kb).
max log size = 1000

# If you want Samba to log though syslog only then set the following
# parameter to 'yes'. Please note that logging through syslog in
# Samba is still experimental.
#syslog only = no

# We want Samba to log a minimum amount of information to syslog. Everything
# should go to /var/log/samba/log.{smb,nmb} instead. If you want to log
# through syslog you should set the following parameter to something higher.
#   syslog = 0
# "security = user" is always a good idea. This will require a Unix account
# in this server for every user accessing the server. See
# security_level.txt for details.
#TEMA ADS
debug level = 2
realm = ASECORD.COM
security = ADS
idmap uid = 20000-30000
idmap gid = 20000-30000
#winbind separator = +
winbind enum users = yes
winbind enum groups = yes
template homedir = /home/%D/%U
template shell = /bin/false
#client use spnego = yes

# You may wish to use password encryption. Please read ENCRYPTION.txt,
# Win95.txt and WinNT.txt in the Samba documentation. Do not enable this
# option unless you have read those documents
   encrypt passwords = true
   passdb backend = smbpasswd guest
   password server = w2kserver

# Using the following line enables you to customise your configuration
# on a per machine basis. The %m gets replaced with the netbios name
# of the machine that is connecting
;   include = /home/samba/etc/smb.conf.%m

# Most people will find that this option gives better performance.
# See speed.txt and the manual pages for details
# You may want to add the following on a Linux system:
#         SO_RCVBUF=8192 SO_SNDBUF=8192
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

# --- Browser Control Options ---

# Please _read_ BROWSING.txt and set the next four parameters according
# to your network setup. The defaults are specified below (commented
# out.) It's important that you read BROWSING.txt so you don't break
# browsing in your network!
                                                                               
                            
# set local master to no if you don't want Samba to become a master
# browser on your network. Otherwise the normal election rules apply
local master = no

# OS Level determines the precedence of this server in master browser
# elections. The default value should be reasonable
os level = 20

# Domain Master specifies Samba to be the Domain Master Browser. This
# allows Samba to collate browse lists between subnets. Don't use this
# if you already have a Windows NT domain controller doing this job
;   domain master = auto

# Preferred Master causes Samba to force a local browser election on startup
# and gives it a slightly higher chance of winning the election
;   preferred master = auto

# --- End of Browser Control Options ---

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable it's WINS Server
;   wins support = no

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
#ote: Samba can be either a WINS Server, or a WINS Client, but NOT both
wins server = 192.168.0.30

# If we receive WINS server info from DHCP, override the options above.
   include = /etc/samba/dhcp.conf

# This will prevent nmbd to search for NetBIOS names through DNS.
   dns proxy = no

# What naming service and in what order should we use to resolve host names
# to IP addresses
;   name resolve order = lmhosts host wins bcast

# Name mangling options
;   preserve case = yes
# Name mangling options
;   preserve case = yes
;   short preserve case = yes

# This boolean parameter controlls whether Samba attempts to sync. the Unix
# password with the SMB password when the encrypted SMB password in the
# /etc/samba/smbpasswd file is changed.
;   unix password sync = false

# For Unix password sync. to work on a Debian GNU/Linux system, the following
# parameters must be set (thanks to Augustin Luton <aluton@hybrigenics.fr> for
# sending the correct chat script for the passwd program in Debian Potato).
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\sUNIX\spassword:* %n\n
*Retype\snew\sUNIX\spassword:* %n\n .

# This boolean controls whether PAM will be used for password changes
# when requested by an SMB client instead of the program listed in
# 'passwd program'. The default is 'no'.
;   pam password change = no

# The following parameter is useful only if you have the linpopup package
# installed. The samba maintainer and the linpopup maintainer are
# working to ease installation and configuration of linpopup and samba.
;   message command = /bin/sh -c '/usr/bin/linpopup "%f" "%m" %s; rm %s' &

   obey pam restrictions = yes

# Some defaults for winbind (make sure you're not using the ranges
# for something else.)
;   winbind uid = 10000-20000
;   winbind gid = 10000-20000
;   template shell = /bin/bash

#======================= Share Definitions =======================

;[netlogon]
;   comment = Network Logon Service
;   path = /home/samba/netlogon
;   guest ok = yes
;   writable = no
;   share modes = no
;   share modes = no

[printers]
   comment = Impresoras
   browseable = no
   path = /var/spool/samba
   printable = yes
   public = no
   writable = no
   create mode = 0777
   printer admin = root, ASECORD\skuda, "@ASECORD\Usuarios del dominio",
"@ASECORD\Admins. del dominio"
   write list = root, ASECORD\skuda, "@ASECORD\Usuarios del dominio",
"@ASECORD\Admins. del dominio"
   guest ok = yes
   use client driver = yes
#   print command = lpr -P %p -o raw %s -r
#   lpq command = lpstat -o %p
#   lprm command = cancel %p-%j

#[print$]
#    comment = Printer Driver Download area
#    path = /var/lib/samba/printers
#    browseable = no
#    guest ok = yes
#    read only = no
#    write list = ASECORD\skuda, root, "@ASECORD\Usuarios del dominio",
"@ASECORD\Admins. del dominio"
#    printer admin = root, ASECORD\skuda, "@ASECORD\Usuarios del dominio",
"@ASECORD\Admins. del dominio"
#    #default devmode = yes
#    admin users = root, ASECORD\skuda, "@ASECORD\Usuarios del dominio",
"@ASECORD\Admins. del dominio"
#    create mask = 0644
#    directory mask = 0755


krb5.conf
[logging]
        default = FILE:/var/log/krb5libs.log
        kdc = FILE:/var/log/krb5kdc.log
        admin_server = FILE:/var/log/kadmind.log

[libdefaults]
        default_realm = ASECORD.COM
        dns_lookup_realm = false
        dns_lookup_kdc = false

[realms]
ASECORD.COM = {
        kdc = w2kserver.asecord.com:88
        admin_server = w2kserver.asecord.com:749
        default_domain = asecord.com
}

[domain_realm]
        .asecord.com = ASECORD.COM

I have other bug report that can be related so i will explain here, it´s a
winbind error, it´s the same version 3.0.2a, this is the log.
log.winbind

[2004/03/08 18:28:21, 1] libads/ads_ldap.c:ads_name_to_sid(64)
  name_to_sid: carmen_prieto not found
[2004/03/08 18:28:21, 1] nsswitch/winbindd_user.c:winbindd_getpwnam(157)
  user 'carmen_prieto' does not exist
[2004/03/08 18:28:21, 1] libads/ads_ldap.c:ads_name_to_sid(64)
  name_to_sid: carmen_prieto not found
[2004/03/08 18:28:21, 1] nsswitch/winbindd_group.c:winbindd_getgroups(954)
  user 'carmen_prieto' does not exist
[2004/03/08 18:28:21, 1] libads/ads_ldap.c:ads_name_to_sid(64)
  name_to_sid: carmen_prieto not found
[2004/03/08 18:28:21, 1] nsswitch/winbindd_user.c:winbindd_getpwnam(157)
  user 'carmen_prieto' does not exist
winbindd:
/home/tretkowski/openldap2/openldap2-2.1.26/libraries/libldap/getvalues.c:36:
ldap_get_values: Assertion `entry != ((void *)0)' failed.
[2004/03/08 18:28:21, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2004/03/08 18:28:21, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 6 in pid 414 (3.0.2a-Debian)
  Please read the appendix Bugs of the Samba HOWTO collection
[2004/03/08 18:28:21, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2004/03/08 18:28:21, 0] lib/util.c:smb_panic(1390)
  smb_panic(): calling panic action [/usr/share/samba/panic-action 414]
[2004/03/08 18:28:25, 0] lib/util.c:smb_panic(1398)
  smb_panic(): action returned status 0
[2004/03/08 18:28:25, 0] lib/util.c:smb_panic(1400)
  PANIC: internal error
[2004/03/08 18:28:25, 0] lib/util.c:smb_panic(1408)
  BACKTRACE: 19 stack frames:
   #0 /usr/sbin/winbindd(smb_panic+0x16b) [0x80b3db3]
   #1 /usr/sbin/winbindd [0x80a4a03]
   #2 /usr/sbin/winbindd [0x80a4a65]
   #3 /lib/libc.so.6 [0x401534a8]
   #4 /lib/libc.so.6(abort+0x178) [0x40154838]
   #5 /lib/libc.so.6(__assert_fail+0x10f) [0x4014ca4f]
   #6 /usr/lib/libldap.so.2(ldap_get_values+0x87) [0x40104f87]
   #7 /usr/sbin/winbindd(ads_pull_uint32+0x1a) [0x813339e]
   #8 /usr/sbin/winbindd(ads_sid_to_name+0x18a) [0x8137e12]
   #9 /usr/sbin/winbindd [0x807ee3c]
   #10 /usr/sbin/winbindd [0x807629d]
   #11 /usr/sbin/winbindd(winbindd_lookup_name_by_sid+0xa1) [0x8072e3d]
   #12 /usr/sbin/winbindd(winbindd_getpwuid+0x165) [0x806ea01]
   #13 /usr/sbin/winbindd(ber_scanf+0x6bc) [0x806d0cc]
   #14 /usr/sbin/winbindd(winbind_process_packet+0x20) [0x806d380]
   #15 /usr/sbin/winbindd(do_dual_daemon+0x1bf) [0x8080b27]
   #16 /usr/sbin/winbindd(main+0x407) [0x806e0d7]
   #17 /lib/libc.so.6(__libc_start_main+0xc6) [0x4013fdc6]
   #18 /usr/sbin/winbindd(ldap_msgfree+0x61) [0x806ca91]

If you have any questions don´t doubt to contact me.
Comment 1 Gerald (Jerry) Carter 2004-03-11 13:35:42 UTC
The first crash in print_queue_status() is already fixed in cvs.
See bug 1147 for details.  I'm changing the summary line to reflect 
the winbindd portion of the report.
Comment 2 Gerald (Jerry) Carter 2004-03-12 08:16:40 UTC

*** This bug has been marked as a duplicate of 1127 ***
Comment 3 Gerald (Jerry) Carter 2005-11-14 09:26:17 UTC
database cleanup