Bug 11617 - make fail with error "task: cc time.c -> time_11.o"
make fail with error "task: cc time.c -> time_11.o"
Status: RESOLVED DUPLICATE of bug 11214
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Build
4.3.1
PPC AIX
: P5 major
: ---
Assigned To: Samba QA Contact
Samba QA Contact
https://bugzilla.samba.org/show_bug.c...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 12:40 UTC by Pradip Jha
Modified: 2015-11-24 18:46 UTC (History)
2 users (show)

See Also:


Attachments
Package_details (2.19 KB, text/plain)
2015-11-24 12:40 UTC, Pradip Jha
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pradip Jha 2015-11-24 12:40:27 UTC
Created attachment 11614 [details]
Package_details

Hardware details :- 

\System Model: IBM,9117-MMC
Machine Serial Number: 659E69E
Processor Type: PowerPC_POWER7
Processor Implementation Mode: POWER 7
Processor Version: PV_7_Compat

used command :- 

CPPFLAGS='-I/opt/freeware/include' LDFLAGS=' -L/opt/freeware/lib' ./configure  --check-c-compiler=xlc --with-ads   --prefix=/opt/samba4  --sysconfdir=/etc/samba4   --localstatedir=/var  --with-statedir=/var/lib/samba4   --with-privatedir=/var/lib/samba4/private  --with-piddir=/var/run/samba4  --with-cachedir=/var/lib/samba4/private   --with-lockdir=/var/lock/samba4 --with-logfilebase=/var/log/samba4 --with-sockets-dir=/var/run/samba4   --with-configdir=/etc/samba4 

Error Details :- 

[ 589/3779] Compiling lib/util/signal.c
"../lib/util/time.c", line 63.5: 1506-294 (S) Syntax error in expression on #if directive.
Waf: Leaving directory `/home/BB7759/samba-4.3.1/bin'
Build failed:  -> task failed (err #1): 
        {task: cc time.c -> time_11.o}
make: 1254-004 The error code from the last command is 1.

Please help me ASAP, it is to urgent ....
Comment 1 Christian Ambach 2015-11-24 18:46:55 UTC
Probably a dupe of the still unresolved Bug 11214.
However, other people seem to be able to build on AIX successfully, so there might be CFLAGS missing.

*** This bug has been marked as a duplicate of bug 11214 ***