Bug 1159 - dos filemode=yes isn't working
dos filemode=yes isn't working
Status: RESOLVED DUPLICATE of bug 2239
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.2a
All Linux
: P3 normal
: none
Assigned To: Jeremy Allison
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-08 04:03 UTC by Jörg Redemann
Modified: 2005-02-22 16:34 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jörg Redemann 2004-03-08 04:03:38 UTC
I have exactly the same issue on samba 3.0.2a - with parameter 'dos 
filemode=yes' still only the owner can set permissions on files and 
directories.

I'm also using ACL support and user accounts from winbind.

Mike

Joerg Redemann wrote:
> Hi folks,
>  
> I'm trying to set up a share with samba 2.2.8a (SuSE SLES 8) with ACL
> support and winbind where every user with write access to a file should
> be able to change the permissions of that file.
>  
> According to the man page "dos filemode = yes" should do it - but not for
> me. It seems that this param is doing nothing at all.
> I'm I dump ?? What could be wrong here ??
>  
> Here's my config:
>  
> [testshare]
>     comment = Test share
>     path = /shares/test
>     writable = yes
>     create mode = 660
>     directory mode = 770
>     dos filemode = yes
> 
> And yes : the connected user is of course member of the group that has
> read/write access.
> Everything is working a expected - but not that "dos filemode" param.
>  
> Any clues ??
> Joerg

PS : For me it doesn't seem to work without ACL's and without winbind at all.
Tried both Samba Versions 3.0.2a and 2.2.8a.

Joerg
Comment 1 Gerald (Jerry) Carter 2004-05-27 16:16:44 UTC
Jeremy, care to spend a few cycles on this one ?  Thanks.
Comment 2 Alex Karle 2005-01-12 23:24:46 UTC
I'm using samba 3.0.10 and having the same Problem.
The only thing the parameter changes is that the user
who has write access to the file, can change ownership.


Alex 
(In reply to comment #0)
> I have exactly the same issue on samba 3.0.2a - with parameter 'dos 
> filemode=yes' still only the owner can set permissions on files and 
> directories.
> 
> I'm also using ACL support and user accounts from winbind.
> 
> Mike
> 
> Joerg Redemann wrote:
> > Hi folks,
> >  
> > I'm trying to set up a share with samba 2.2.8a (SuSE SLES 8) with ACL
> > support and winbind where every user with write access to a file should
> > be able to change the permissions of that file.
> >  
> > According to the man page "dos filemode = yes" should do it - but not for
> > me. It seems that this param is doing nothing at all.
> > I'm I dump ?? What could be wrong here ??
> >  
> > Here's my config:
> >  
> > [testshare]
> >     comment = Test share
> >     path = /shares/test
> >     writable = yes
> >     create mode = 660
> >     directory mode = 770
> >     dos filemode = yes
> > 
> > And yes : the connected user is of course member of the group that has
> > read/write access.
> > Everything is working a expected - but not that "dos filemode" param.
> >  
> > Any clues ??
> > Joerg
> 
> PS : For me it doesn't seem to work without ACL's and without winbind at all.
> Tried both Samba Versions 3.0.2a and 2.2.8a.
> 
> Joerg

Comment 3 Gerald (Jerry) Carter 2005-02-22 16:34:50 UTC

*** This bug has been marked as a duplicate of 2239 ***