Bug 11567 - OSX, Samba 4.2, Fruit: Microsoft Excel cannot access the file
OSX, Samba 4.2, Fruit: Microsoft Excel cannot access the file
Status: RESOLVED INVALID
Product: Samba 4.1 and newer
Classification: Unclassified
Component: File services
4.2.4
x86 Linux
: P5 normal
: ---
Assigned To: Ralph Böhme
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-22 09:18 UTC by sts
Modified: 2015-11-11 09:04 UTC (History)
1 user (show)

See Also:


Attachments
samba-office-cannot-save-to-share.pcap (298.26 KB, application/vnd.tcpdump.pcap)
2015-10-22 09:19 UTC, sts
no flags Details
Logfile (923.93 KB, application/x-gzip)
2015-10-28 17:10 UTC, sts
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description sts 2015-10-22 09:18:49 UTC
When trying to save Workbook1.xslx, to the share 'teamtech', the following error comes up:

    -------------------------------------------------------------------
    Microsoft Excel cannot access the file 'teamtech:0A5D9610'.

    There are several possible reasons:
    * The file or path name does not exist.
    * The file you're trying to open is being used by another program.
      Close the document in the other program, and try again.
    * The name of the workbook you're trying to save is the same as the
      name of another document that is read-only. Try saving the
      workbook with a different name.
    -------------------------------------------------------------------

Excel still creates a temporary file with the name from the error message, so in this case I end up with a file called 0A5D9610 on the share.

Attached is a packet trace and the logs from the moment on, when we tried to save the file. Packet trace seems to be interesting at packet #524, the log file contains interesting things around at 2015/10/22 08:24:33.425935, just look out for 0A5D9610.
Comment 1 sts 2015-10-22 09:19:23 UTC
Created attachment 11524 [details]
samba-office-cannot-save-to-share.pcap
Comment 2 sts 2015-10-27 19:49:01 UTC
Any updates to this bug?

I found other reports as well such as #11107 and the last comment in #10592 seems to have the same issue.
Comment 3 Ralph Böhme 2015-10-28 12:46:41 UTC
Logfile is missing.
Comment 4 sts 2015-10-28 17:10:07 UTC
Created attachment 11549 [details]
Logfile

Sorry I uploaded the pcap twice.
Comment 5 sts 2015-11-02 17:56:32 UTC
Issue was reproducible on OSX Yosemite and El Capitan for us, both with Excel 14.5.7.
Comment 6 sts 2015-11-11 09:04:06 UTC
The issue could be resolved by altering the configuration. The following worked for us:

[global]
    ea support = yes
    store dos attributes = yes

[shared]
    vfs objects = catia fruit streams_xattr
    fruit:aapl = yes
    fruit:encoding = native
    fruit:locking = none
    fruit:metadata = netatalk
    fruit:resource = file