Bug 11558 - rsync always try change owner and group of symlink in --fake-super mode
rsync always try change owner and group of symlink in --fake-super mode
Status: NEW
Product: rsync
Classification: Unclassified
Component: core
3.1.2
x64 Linux
: P5 normal
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 09:54 UTC by Pavel Alexeev
Modified: 2015-10-15 09:54 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Alexeev 2015-10-15 09:54:20 UTC
Hi.

I long time discover strange to me behavior. If I add --fake-super
option on both sides rsync start always set owner and group of symlink.
What interesting there no error, but it done each time as it has been
changed.

Simple reproduce:
$ mkdir rsync.symlinks
$ echo 'file content' > rsync.symlinks/file.itself
$ ln -s file.itself rsync.symlinks/file.symlink

Then try to transfer it on remote host:
$ rsync -apr --links --itemize-changes --fake-super -M--fake-super
rsync.symlinks backup@store.hubbitus.info:~/temp/rsync.symlinks
cd+++++++++ rsync.symlinks/
<f+++++++++ rsync.symlinks/file.itself
cL+++++++++ rsync.symlinks/file.symlink -> file.itself

And again:
.L....og... rsync.symlinks/file.symlink -> file.itself


I had tried use --rsync-path="rsync --fake-super" instead of
-M--fake-super what unsurprisingly give me same result:
$ rsync -apr --links --itemize-changes --fake-super --rsync-path="rsync
--fake-super" rsync.symlinks
backup@store.hubbitus.info:~/temp/rsync.symlinks
.L....og... rsync.symlinks/file.symlink -> file.itself

I had post it in mail list - http://samba.2283325.n4.nabble.com/rsync-always-try-change-owner-and-group-of-symlink-in-fake-super-mode-td4692664.html but does not receive intelligible answer.

Possibly relates to https://bugzilla.samba.org/show_bug.cgi?id=10496

With best wishes, Pavel Alexeev.