Bug 11547 - vfs_commit fails all file opens for "hinted" and "growth" eof modes
vfs_commit fails all file opens for "hinted" and "growth" eof modes
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: VFS Modules
4.3.0
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-07 19:46 UTC by Uri Simchoni
Modified: 2015-10-19 08:50 UTC (History)
3 users (show)

See Also:


Attachments
git-am fix for 4.3.next and 4.2.next (1.41 KB, patch)
2015-10-08 05:41 UTC, Uri Simchoni
uri: review?
jra: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Uri Simchoni 2015-10-07 19:46:25 UTC
** This bug was found by code analysis, no reproduction attempted

vfs_commit has an "eof mode" parameter (commit:eof mode=none/hinted/growth).
The default is none (meaning that "commits" are done at configured intervals only).
When set to "hinted", an additional commit should be done when the number of bytes written first reaches the original file size.
When set to "growth", an additional commit is done whenever the file grows.

In practice, setting this flag to anything but "none" causes all file opens in the share to fail, because an fstat with an uninitialized file descripter is attempted.
Comment 1 Uri Simchoni 2015-10-08 05:41:30 UTC
Created attachment 11484 [details]
git-am fix for 4.3.next and 4.2.next
Comment 2 Jeremy Allison 2015-10-08 18:27:40 UTC
Comment on attachment 11484 [details]
git-am fix for 4.3.next and 4.2.next

LGTM.
Comment 3 Jeremy Allison 2015-10-08 18:28:02 UTC
Re-assigning to Karolin for inclusion in 4.3.next, 4.2.next.
Comment 4 Karolin Seeger 2015-10-12 19:32:56 UTC
(In reply to Jeremy Allison from comment #3)
Pushed to autobuild-v4-[2|3]-test.
Comment 5 Karolin Seeger 2015-10-19 08:50:31 UTC
(In reply to Karolin Seeger from comment #4)
Pushed to both branches.
Closing out bug report.

Thanks!