Bug 11542 - Installing wbinfo.inst gets versioned TBD symbol error
Installing wbinfo.inst gets versioned TBD symbol error
Status: NEW
Product: TDB
Classification: Unclassified
Component: libtdb
unspecified
All All
: P5 normal
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-05 17:21 UTC by Lee Merrill
Modified: 2015-10-05 17:21 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lee Merrill 2015-10-05 17:21:44 UTC
When building Samba 4.1 on SLES 10 SP1, 64-bit, the install fails due to a mismatch of versioned symbols in tdb:

15:10:32 runner /usr/bin/gcc default/nsswitch/wbinfo_18.o default/source4/lib/cmdline/popt_common_5.o default/lib/afs/afs_settoken_2.o -o /usr/src/samba-4.3.0/bin/default/nsswitch/wbinfo.inst -pie -Wl,-z,relro,-z,now -lpthread -Wl,-no-undefined -Wl,--export-dynamic -Wl,--as-needed -fstack-protector -Wl,-rpath,/usr/local/samba/lib -Wl,-rpath,/usr/local/samba/lib/private -Ldefault/lib/tdb_wrap -Ldefault/source4/heimdal_build -Ldefault/libcli/security -Ldefault/lib/dbwrap -Ldefault/librpc -Ldefault/lib/krb5_wrap -Ldefault/libcli/util -Ldefault/lib/tdb -Ldefault/nsswitch -Ldefault/lib/tevent -Ldefault/libcli/auth -Ldefault/lib/param -Ldefault/lib/replace -Ldefault/nsswitch/libwbclient -Ldefault/lib/util -L/usr/local/lib -Wl,-Bdynamic -lsamba-util -lwbclient -lreplace-samba4 -lsamba-hostconfig -lcliauth-samba4 -ltime-basic-samba4 -lutil-setid-samba4 -lsamba-debug-samba4 -lgenrand-samba4 -lsocket-blocking-samba4 -ltevent -lwinbind-client-samba4 -ltdb -lserver-role-samba4 -lerrors-samba4 -lutil-tdb-samba4 -lasn1util-samba4 -lkrb5samba-samba4 -lndr-samba-samba4 -lndr-nbt -lndr -ldbwrap-samba4 -lsamba-security-samba4 -lkrb5-samba4 -lcom_err-samba4 -lgssapi-samba4 -lasn1-samba4 -lndr-krb5pac -lndr-standard -ltdb-wrap-samba4 -lheimbase-samba4 -lhx509-samba4 -lhcrypto-samba4 -lroken-samba4 -lwind-samba4 -lresolv -lutil -lz -lrt -ldl -lnsl -lattr -lcrypt -lpopt
/usr/src/samba-4.3.0/bin/shared/private/libtdb-wrap-samba4.so: undefined reference to `tdb_open_ex@TDB_1.2.1'
/usr/src/samba-4.3.0/bin/shared/private/libutil-tdb-samba4.so: undefined reference to `tdb_parse_record@TDB_1.2.1'
/usr/src/samba-4.3.0/bin/shared/private/libdbwrap-samba4.so: undefined reference to `tdb_traverse@TDB_1.2.1'
/usr/src/samba-4.3.0/bin/shared/private/libutil-tdb-samba4.so: undefined reference to `tdb_chainunlock_read@TDB_1.2.1'
/usr/src/samba-4.3.0/bin/shared/private/libdbwrap-samba4.so: undefined reference to `tdb_traverse_read@TDB_1.2.1'
/usr/src/samba-4.3.0/bin/shared/private/libdbwrap-samba4.so: undefined reference to `tdb_exists@TDB_1.2.1'
etc.