Bug 11541 - "use slp" directive removed from slp.diff during migration to 3.1.0
"use slp" directive removed from slp.diff during migration to 3.1.0
Status: NEW
Product: rsync
Classification: Unclassified
Component: core
3.1.2
All All
: P5 normal
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-05 14:59 UTC by Vitezslav Cizek
Modified: 2015-10-05 14:59 UTC (History)
0 users

See Also:


Attachments
add an option to disable slp (17.54 KB, patch)
2015-10-05 14:59 UTC, Vitezslav Cizek
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vitezslav Cizek 2015-10-05 14:59:28 UTC
Created attachment 11477 [details]
add an option to disable slp

There existed a "use slp" directive (brought by slp.diff) during 3.0.x times.
It was omitted (or perhaps intentionally removed?) during the 3.1.x porting.
Was there a specific reason for this?

At the moment, there's no way to disable slp, when it's compiled in.
rsync always tries to register the services over slp and that results in errors and spams system log.

Eg see https://bugzilla.opensuse.org/show_bug.cgi?id=922710.

I'm attaching a modified slp.diff, which reintroduces the "use slp" global parameter.