Bug 11497 - python2.7 segmentation fault on samba-tool domain provision - unable to start samba service
python2.7 segmentation fault on samba-tool domain provision - unable to start...
Status: RESOLVED DUPLICATE of bug 11455
Product: Samba 4.1 and newer
Classification: Unclassified
Component: AD: LDB/DSDB/SAMDB
4.2.3
x86 FreeBSD
: P5 critical
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-06 13:00 UTC by webmst
Modified: 2015-09-06 15:37 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description webmst 2015-09-06 13:00:13 UTC
Hi eveybody,
I'm trying to use SAMBA-4.2.3 on FREEBSD-10.1-RELEASE after an upgrade from a working SAMBA-4.1.18.

Trying to execute the 'samba-tool' utility to provision a domain controller, I get an unrecoverable 'segmentation fault' due to python2.7.

This is the tail of the python2.7.core GDB trace:

#0  0x28ed05c3 in rep_strtoll () from /usr/local/lib/libldb.so.1
[New Thread 28803080 (LWP 100325/python2.7)]

Trying to reinstall the 'ldb' package (deeming it responsible as it has just been upgraded to 1.1.21 in order to support SAMBA4.2) doesn't solve the issue.

I'm also unable to start the samba server service, as the samba daemon aborts with 'illegal instruction', as you can see on the GDB trace: 

Program terminated with signal 4, Illegal instruction.
#0  0x21c765c3 in ?? ()
Comment 1 Volker Lendecke 2015-09-06 15:37:46 UTC
This is a dup of 11455. Please see the patches there.

*** This bug has been marked as a duplicate of bug 11455 ***