Bug 11437 - Samba4 impossible to read/copy if accessing from Android devices (jcifs)
Samba4 impossible to read/copy if accessing from Android devices (jcifs)
Product: Samba 4.1 and newer
Classification: Unclassified
Component: File services
All Linux
: P5 normal
: ---
Assigned To: Jeremy Allison
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2015-08-07 18:03 UTC by Jiri Wichern
Modified: 2015-09-04 23:29 UTC (History)
1 user (show)

See Also:

My current smb.conf (2.03 KB, text/plain)
2015-09-04 23:20 UTC, Jiri Wichern
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Wichern 2015-08-07 18:03:16 UTC
This bug seems to still be in effect:

https://bugzilla.samba.org/show_bug.cgi?id=9706 (Samba 4.0)

I've tested various recent versions of Android apps using jcifs and none can copy a file from a Samba4 file server to the device. Copying from the device to server works fine, as do renames and folder traversal.

Apps I tried: ES File Explorer, Ghost Commander (with SMB plugin) and AndSMB.

The error on the jcifs side: "Signature verification failed".

Versions of Samba I compiled and tested: 4.2.2 and 4.3.0rc1.
Samba 3 servers on my network communicate just fine with the apps using jcifs as do all Windows versions I have access to (Windows XP, Vista, 7, 8.1).

This may actually be a bug in jcifs. However the Samba 4.0 bug reports suggests it was fixed server-side.

I also tried to apply this patch to my 4.3.0rc1 source (source3/smbd/reply.c):


but the source has changed so much between versions 4.0 and 4.3 that I was unable to write comparable code for the 4.3 version.
Comment 1 Jeremy Allison 2015-08-27 23:16:27 UTC
What does your smb.conf look like ? Have you made smb signing mandatory ?
Comment 2 Jiri Wichern 2015-09-04 23:20:34 UTC
Created attachment 11413 [details]
My current smb.conf
Comment 3 Jiri Wichern 2015-09-04 23:23:28 UTC
Comment on attachment 11413 [details]
My current smb.conf

As far as I know, I haven't configured mandatory signing...
Comment 4 Jeremy Allison 2015-09-04 23:29:24 UTC
So, just trying to get more info. Do the jcifs clients fail with all Samba 4.0.x and above versions, or do they fail with 4.0.x but work with 4.1.x and above ?

Can you attach a wireshark trace between client and server showing the failure ?

Can you give an *exact* method of reproducing this I can try with an Android phone ?