Bug 1141 - special names for NSS modules under FreeBSD
special names for NSS modules under FreeBSD
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.2a
All FreeBSD
: P3 trivial
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-29 14:45 UTC by Timur Bakeyev
Modified: 2005-11-14 09:24 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timur Bakeyev 2004-02-29 14:45:19 UTC
Under FreeBSD(5.x) NSS modules need to have name, that falls into /nss_\w+.so.1/
pattern to be recognized an picked up. This small patch does half of the job,
i.e. create nss_winbind.so and nss_wins.so names for modules. Possibly, it
should hardcode '.1' suffix as well(it's really necessary!).

Please, comment.

--- configure.in.orig   Sat Jan 31 04:40:54 2004
+++ configure.in        Sat Jan 31 04:43:23 2004
@@ -4037,6 +4037,8 @@
                # the Linux version.
                WINBIND_NSS_EXTRA_OBJS="nsswitch/winbind_nss_freebsd.o \
                    nsswitch/winbind_nss_linux.o"
+               WINBIND_NSS="nsswitch/nss_winbind.$SHLIBEXT"
+               WINBIND_WINS_NSS="nsswitch/nss_wins.$SHLIBEXT"
                ;;
        *irix*)
                # IRIX has differently named shared libraries
Comment 1 Tim Potter 2004-03-02 03:16:16 UTC
*** Bug 1140 has been marked as a duplicate of this bug. ***
Comment 2 Gerald (Jerry) Carter 2004-03-18 07:06:03 UTC
moving to 3.0
Comment 3 Gerald (Jerry) Carter 2004-03-18 07:08:42 UTC
resetting component
Comment 4 Timur Bakeyev 2004-04-12 14:36:13 UTC
It will be very helpful if this patch be commited before 3.0.3 release... It's
absence complicates creation and maintainarship of the FreeBSD port.
Comment 5 Gerald (Jerry) Carter 2004-04-28 12:15:41 UTC
Looks ok.  Checkling it into 3.0
Comment 6 Gerald (Jerry) Carter 2005-08-24 10:21:11 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 7 Gerald (Jerry) Carter 2005-11-14 09:24:40 UTC
database cleanup