Bug 11318 - Build fails on Solaris 10 with ‘struct msghdr’ has no member named ‘msg_control’
Build fails on Solaris 10 with ‘struct msghdr’ has no member named ‘msg_control’
Status: RESOLVED DUPLICATE of bug 11053
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Build
unspecified
x86 Solaris
: P5 major
: ---
Assigned To: Björn Jacke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-06-08 12:31 UTC by Dagobert Michelsen
Modified: 2015-07-01 09:04 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dagobert Michelsen 2015-06-08 12:31:17 UTC
The current Samba from Git master does not compile on Solaris 10 x86 with
the following error message:

[1568/3922] Compiling source3/lib/msghdr.c
../source3/lib/msghdr.c: In function ‘msghdr_prep_fds’:
../source3/lib/msghdr.c:35:7: error: ‘struct msghdr’ has no member named ‘msg_control’
    msg->msg_control = NULL;
       ^
../source3/lib/msghdr.c:36:7: error: ‘struct msghdr’ has no member named ‘msg_controllen’
    msg->msg_controllen = 0;
       ^

The detailed build- and configure-logs are linked from the buildbot-page:
  https://buildfarm.opencsw.org/buildbot/waterfall?category=samba
Comment 1 Dagobert Michelsen 2015-07-01 09:04:52 UTC

*** This bug has been marked as a duplicate of bug 11053 ***