Bug 1119 - Nested "include =" files have problems
Nested "include =" files have problems
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: Config Files
3.0.2
All Windows XP
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-23 17:08 UTC by Justin Maggard
Modified: 2005-02-21 06:23 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Maggard 2004-02-23 17:08:22 UTC
I have an "include = /etc/samba/smb.conf.%a" line in my smb.conf in order to
avoid any sendfile issues with older clients.
My /etc/samba/smb.conf.UNKNOWN file reads:
use sendfile = 1
include = /etc/samba/shares.conf

This configuration works for the most part, but SIGHUP causes problems in either
user or domain/ads level security.  Steps to reproduce are:
1) Open a connection to a share on the system
2) Start a large file copy to this share
3) Add another share to shares.conf
4) Send SIGHUP to smbd or wait for smbd to reread the configuration

All shares other than the target for the file copy will disappear from the share
browse list, and will not come back until samba is restarted or the connection
to the system is closed.  Tried with 3.0.0-3.0.2 on x86 running Debian testing
release, and on Sparc running Debian Woody.
Comment 1 Gerald (Jerry) Carter 2004-03-19 07:17:20 UTC
I don't see what this has to do with nested include files ?
To me 'nested' means things like:

## /etc/samba/smb.conf
   ...
   include = foo.conf

# foo.conf

   include = foo2.conf

And after looking at the code, I'm not convinced that nested (in
this sense) ever worked in the 2.2 branch.
Comment 2 Justin Maggard 2004-03-19 18:02:27 UTC
Yes, that is what I'm referring to with "nested" include files.  Smbd will read
in the the configuration from the nested include files properly upon starting
up, but it does not handle configuration rereads in the same way.  I never tried
it with 2.2.
Comment 3 Gerald (Jerry) Carter 2005-02-21 06:23:17 UTC
closing.  low priority unless more people complain.  Only one 
so far.  Sorry.