Bug 11162 - vfs_fruit: xattr imcompatible with netatalk
vfs_fruit: xattr imcompatible with netatalk
Status: RESOLVED DUPLICATE of bug 11278
Product: Samba 4.1 and newer
Classification: Unclassified
Component: VFS Modules
4.2.0
All All
: P5 normal
: 4.3
Assigned To: Ralph Böhme
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-13 15:01 UTC by HAT
Modified: 2015-08-04 12:23 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description HAT 2015-03-13 15:01:34 UTC
I'm testing samba 4.2.0 vfs_fruit on Fedora Server 22-alpha.
I confirmed that ResourceFork and FinderInfo are compatible with Netatalk 3.1.7.
However, EAs are incompatible. The character ":" in EA name is wrong. The EAs are not seen from clients.

smb.conf:
    [test2]
    path = /export/test2
    writable = yes
    vfs objects = catia fruit streams_xattr
    fruit:locking = netatalk
    streams_xattr:prefix = user.
    streams_xattr:store_stream_type = no
    kernel oplocks = no

On OS X:
    $ cd ~/test
    $ xattr ICONandEA.txt
    com.apple.FinderInfo
    com.apple.ResourceFork
    com.apple.TextEncoding
    com.apple.metadata:kMDItemFinderComment

On Fedora:
    $ cd /export/test2
    $ ls -a
    ./
    ../
    .DS_Store
    ._ICONandEA.txt
    ICONandEA.txt
    $ getfattr ICONandEA.txt
    # file: ICONandEA.txt
    user.com.apple.TextEncoding
    user.com.apple.metadatakMDItemFinderComment
    user.org.netatalk.Metadata

The character ":" is wrong. This is the spec of SFM.
":" is converted to "/", and "/" is converted to "0xEF 0x80 0xA2" (U+F022).

On OS X via Samba:
    $ cd /Volumes/test2
    $ xattr ICONandEA.txt
    com.apple.FinderInfo
    com.apple.ResourceFork

The EAs are not seen from clients.
Comment 1 Ralph Böhme 2015-08-04 12:23:09 UTC

*** This bug has been marked as a duplicate of bug 11278 ***