Bug 11100 - Rotated log files are left open in smbd/winbindd child
Rotated log files are left open in smbd/winbindd child
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: AD: LDB/DSDB/SAMDB
4.2.0rc4
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
: 11288 (view as bug list)
Depends on:
Blocks: 10077
  Show dependency treegraph
 
Reported: 2015-02-16 03:01 UTC by Andrew Bartlett
Modified: 2015-05-25 09:38 UTC (History)
4 users (show)

See Also:


Attachments
patch for master (2.08 KB, patch)
2015-02-16 03:21 UTC, Andrew Bartlett
no flags Details
4.2 patch cherry-picked from master (2.27 KB, patch)
2015-02-22 18:12 UTC, Andrew Bartlett
abartlet: review? (metze)
obnox: review+
Details
4.1 patch cherry-picked from master (1.71 KB, patch)
2015-02-23 07:32 UTC, Andrew Bartlett
abartlet: review? (metze)
obnox: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Bartlett 2015-02-16 03:01:43 UTC
The log file in use at the time that smbd and winbindd are in use on the AD DC is left open as an FD in the child, and so when the log is rotated and eventually deleted, the disk space is not reclaimed.
Comment 1 Andrew Bartlett 2015-02-16 03:21:59 UTC
Created attachment 10729 [details]
patch for master

Patches for 4.2 will be uploaded once this autobuilds into master, to get correct GIT hash for the cherry-pick.
Comment 2 Andrew Bartlett 2015-02-22 18:12:45 UTC
Created attachment 10766 [details]
4.2 patch cherry-picked from master
Comment 3 Andrew Bartlett 2015-02-23 07:32:10 UTC
Created attachment 10767 [details]
4.1 patch cherry-picked from master
Comment 4 Michael Adam 2015-02-24 15:43:28 UTC
Comment on attachment 10766 [details]
4.2 patch cherry-picked from master

ACK 4.2
Comment 5 Michael Adam 2015-02-24 15:43:38 UTC
Comment on attachment 10767 [details]
4.1 patch cherry-picked from master

ACK 4.1
Comment 6 Michael Adam 2015-02-24 15:44:05 UTC
Karo, please apply to the release branches.
Comment 7 Karolin Seeger 2015-02-25 19:02:47 UTC
Pushed to autobuild-v4-[1|2]-test.
Comment 8 Karolin Seeger 2015-03-02 20:05:45 UTC
Pushed to all branches.
Closing out bug report.

Thanks!
Comment 9 Andrew Bartlett 2015-05-25 09:38:02 UTC
*** Bug 11288 has been marked as a duplicate of this bug. ***