Bug 11099 - smbd core dump on smbclient access
smbd core dump on smbclient access
Status: NEW
Product: Samba 4.1 and newer
Classification: Unclassified
Component: File services
4.1.16
x64 Linux
: P5 normal
: 4.3
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-02-13 20:17 UTC by majin3.mail
Modified: 2018-09-27 00:56 UTC (History)
2 users (show)

See Also:


Attachments
smb.conf, smbclient log and journalctl for smbd (7.16 KB, text/plain)
2015-02-13 20:17 UTC, majin3.mail
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description majin3.mail 2015-02-13 20:17:57 UTC
Created attachment 10728 [details]
smb.conf, smbclient log and journalctl for smbd

Accessing a samba share using smbclient (like smbclient //hostname/sharename -Uusername) causes a core dump to happen on my system.
Accessing the share using a Windows 8.1 client works fine. Accessing the Windows 8.1 shares using smbclient also works fine.

Logs and smb.conf are attached.

System: Arch x86_64 with 4.1.16 Samba and smbclient (from repository)
Comment 1 majin3.mail 2015-02-13 20:28:32 UTC
A smbd restart actually solved it. I was trying to avoid restarting it because I tried to debug a performance issue that disappears after a restart.
But oh well, can't hurt submitting it I guess.
Comment 2 amitkuma 2018-09-18 06:56:55 UTC
Hello majin3,
smb.conf, coredump are not attached on ticket. Only syslog of samba crash are there.
If you still find issues with latest version of samba, please attach coredump,smb.conf
Comment 3 Andrew Bartlett 2018-09-27 00:56:44 UTC
Samba 4.1 is very old and no longer supported by the Samba Team.

Can you please try and reproduce on a current, supported version?

Thanks,