Bug 11092 - texpect requires routines err and errx
texpect requires routines err and errx
Status: RESOLVED DUPLICATE of bug 10833
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Build
4.2.0rc4
x64 Solaris
: P5 major
: ---
Assigned To: Björn Jacke
Samba QA Contact
:
Depends on:
Blocks: 10077
  Show dependency treegraph
 
Reported: 2015-02-10 16:05 UTC by Tom Schulz
Modified: 2015-03-09 08:14 UTC (History)
1 user (show)

See Also:


Attachments
texpect patch (877 bytes, text/plain)
2015-02-10 16:05 UTC, Tom Schulz
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Schulz 2015-02-10 16:05:49 UTC
Created attachment 10713 [details]
texpect patch

lib/texpect/texpect.c requires header err.h and routines err and errx. These are not supplied by Solaris 10. They are available in the ccan package included in the Samba distribution. Attached is a patch to allow the texpect build to find the ccan routines.

Note that the attached patch also adds signal.h to texpect.c. The need for that is documented in Bug 10833. I could not find a clean way to submit this as two separate patches as the changes are right next to each other.
Comment 1 Tom Schulz 2015-02-25 18:42:17 UTC
A fix for this bug needs to be included in the 4.2.0 release.
Comment 2 Jeremy Allison 2015-02-25 20:59:41 UTC
Fix from master doesn't apply - we need a back-port here.
Comment 3 Tom Schulz 2015-03-03 16:41:23 UTC
This bug is resolved by the patchset attached to bug 10833.
Comment 4 Björn Jacke 2015-03-03 18:03:29 UTC

*** This bug has been marked as a duplicate of bug 10833 ***