Bug 11080 - Printing problems on XP: spoolss: SPOOLSS_GETJOB failed.
Printing problems on XP: spoolss: SPOOLSS_GETJOB failed.
Status: RESOLVED DUPLICATE of bug 10984
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Printing
4.1.16
All All
: P5 normal
: ---
Assigned To: printing-maintainers
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-01-28 15:01 UTC by Marc Muehlfeld
Modified: 2015-01-28 22:46 UTC (History)
1 user (show)

See Also:


Attachments
Screenshot (38.48 KB, image/png)
2015-01-28 15:01 UTC, Marc Muehlfeld
no flags Details
Level 10 Debug Log (567.08 KB, application/octet-stream)
2015-01-28 15:02 UTC, Marc Muehlfeld
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Muehlfeld 2015-01-28 15:01:19 UTC
Created attachment 10678 [details]
Screenshot

After upgrading from 4.1.13 to 4.1.16, we're having problems on old XP clients with printing: Sometimes it works, sometimes it doesn't. Also every other time you try to open the printers properties, it fails. And the status sometimes is "OK" and sometimes "Printer not found, no connection".

In the logs I see then
[2015/01/28 15:48:42.379688,  1, pid=4523] ../librpc/ndr/ndr.c:489(ndr_push_error)
  ndr_push_error(7): Bad subcontext (PUSH) content_size 104 is larger than size_is(0)
[2015/01/28 15:48:42.379730,  0, pid=4523] ../source3/rpc_server/srv_pipe.c:1395(api_rpcTNP)
  api_rpcTNP: \spoolss: SPOOLSS_GETJOB failed.


Is it possible, that this was introduced by one of the fixes in #10905 or #10898?
Comment 1 Marc Muehlfeld 2015-01-28 15:02:30 UTC
Created attachment 10679 [details]
Level 10 Debug Log
Comment 2 David Disseldorp 2015-01-28 15:12:26 UTC
As mentioned via IRC, I expect this is a duplicate of Bug 10984. Please test the corresponding fix (which is queued for 4.1.17), and update the bug accordingly.
Comment 3 Marc Muehlfeld 2015-01-28 22:46:24 UTC
(In reply to David Disseldorp from comment #2)
I've tested the patch from #10984 with 4.1.6 and it fixes the problem. Closing this bug report as a duplicate of #10984.

*** This bug has been marked as a duplicate of bug 10984 ***