Bug 11025 - Process using 100% CPU - winbind_server
Process using 100% CPU - winbind_server
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Winbind
4.1.14
x64 Linux
: P5 critical
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-30 11:41 UTC by BAndrade (mail address dead)
Modified: 2017-01-03 07:34 UTC (History)
4 users (show)

See Also:


Attachments
Strace -ff -p (6.47 KB, text/plain)
2014-12-30 11:41 UTC, BAndrade (mail address dead)
no flags Details
Sysdig "proc.pid=" output (28.62 KB, text/plain)
2014-12-30 11:42 UTC, BAndrade (mail address dead)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description BAndrade (mail address dead) 2014-12-30 11:41:11 UTC
Created attachment 10568 [details]
Strace -ff -p

I have a multi-DC domain.

I had serner-samba 4.1.6 installed and updated to 4.1.14, but the problem continues.

After I start samba, a process starts consuming almost 100% CPU and via 'samba-tool processes' I found that this process is winbind-server.

I attached the strace and sysdig of the process.

Also, I found this open bug... should be a similar problem - https://bugzilla.samba.org/show_bug.cgi?id=10714
Comment 1 BAndrade (mail address dead) 2014-12-30 11:42:20 UTC
Created attachment 10569 [details]
Sysdig "proc.pid=" output
Comment 2 Richard Sharpe 2014-12-30 20:29:02 UTC
Is this still happening?

See this bug for one like this that has already been fixed:

https://bugzilla.samba.org/show_bug.cgi?id=10358
Comment 3 BAndrade (mail address dead) 2014-12-30 21:02:09 UTC
That bug was already corrected in samba 4.1.14, the version I have installed.

That problem persists.
Comment 4 BAndrade (mail address dead) 2014-12-30 21:03:13 UTC
Sorry, my problem persists. Don't now if it's directly related to that bug, but I have the latest samba version installed
Comment 5 Richard Sharpe 2014-12-30 21:26:51 UTC
Can you attach to the offending process with GDB and get us a traceback?
Comment 6 BAndrade (mail address dead) 2014-12-31 12:58:06 UTC
We're using the Domain Controller as file server. Today we're are testing running another host as domain member and file server. Later today, I'll inform in here the results and if improved the performance and decreases the CPU usage.
Comment 7 BAndrade (mail address dead) 2015-01-05 10:34:10 UTC
Hey,

After configuring a file server in another machine, the problem is solved.

As said on samba4 wiki, it's not recommended using Domain Controller as file server because samba internal winbind, and we verified that the hard way.

Regards,
Bruno Andrade.
Comment 8 Dron 2015-03-05 07:19:13 UTC
Hello.
Anyway this is not normal.
I am testing Samba 4.1.17 on Freebsd 10.1 amd64.
I have 100% CPU usage by samba process even on compiled programm install, when winbind enabled in nssswitch.conf
Comment 9 Andrew Bartlett 2017-01-03 07:34:12 UTC
The internal winbind that is giving the issue here was replaced by the source3 winbindd code in Samba 4.3.  Therefore this issue will have been resolved.

Thanks!