Bug 10992 - winbindd cause samba (DC mode) to crash with "Failed to fetch our own, local AD domain join password for winbindd's internal use"
winbindd cause samba (DC mode) to crash with "Failed to fetch our own, local ...
Status: RESOLVED DUPLICATE of bug 10991
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Winbind
4.2.0rc2
x64 Linux
: P5 regression
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-07 19:21 UTC by nrevel
Modified: 2014-12-08 09:09 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nrevel 2014-12-07 19:21:35 UTC
My configuration is
DC1: (first DC upgraded with calssicupgrade to AD with 4.1.13) now under 4.2.0rc2
DC2: joined and promoted as a DC with 4.1.13 now under 4.2.0rc2

DC1 and DC2 use BIND9_DLZ dns backend
DC2 works well

with no modification in smb.conf, winbindd cause samba to crash with this lines in log:
/usr/sbin/winbindd: winbindd version 4.2.0rc2-18.1-3327-SUSE-oS13.1-x86_64 started.
/usr/sbin/winbindd: Copyright Andrew Tridgell and the Samba Team 1992-2014
/usr/sbin/winbindd: debug_lookup_classname(winbindd): Unknown class
/usr/sbin/winbindd: Maximum core file size limits now 16777216(soft) -1(hard)
/usr/sbin/winbindd: Registered MSG_REQ_POOL_USAGE
/usr/sbin/winbindd: Registered MSG_REQ_DMALLOC_MARK and LOG_CHANGED
/usr/sbin/winbindd: lp_load_ex: refreshing parameters
/usr/sbin/winbindd: Initialising global parameters
/usr/sbin/winbindd: rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
/usr/sbin/winbindd: Processing section "[global]"
/usr/sbin/winbindd: added interface enp2s0 ip=192.168.2.8 bcast=192.168.2.255 netmask=255.255.255.0
/usr/sbin/winbindd: added interface enp2s0 ip=192.168.2.8 bcast=192.168.2.255 netmask=255.255.255.0
/usr/sbin/winbindd: initialize_winbindd_cache: clearing cache and re-creating with version number 2
/usr/sbin/winbindd: Added domain BUILTIN (null) S-1-5-32
/usr/sbin/winbindd: Added domain XXXXXX XXXXXX.windows S-1-5-21-9999999999-9999999999-999999999
/usr/sbin/winbindd: Failed to fetch our own, local AD domain join password for winbindd's internal use
/usr/sbin/winbindd: unable to initialize domain list

This is my smb.conf
# Global parameters
[global]
        log level = 3 winbindd:255
        workgroup = XXXXXX 
        realm = XXXXXX.windows
        netbios name = DC1
        server role = active directory domain controller
        idmap_ldb:use rfc2307 = yes
        #server services = -dns +winbind -winbindd
        server services = -dns
        tls enabled = yes
        tls keyfile  = tls/DC1.key
        tls certfile = tls/DC2.pem
        tls cafile   = tls/CA.pem
        dsdb:schema update allowed = true
[netlogon]
        path = /var/lib/samba/sysvol/XXXXXX.windows/scripts
        read only = No

[sysvol]
        path = /var/lib/samba/sysvol
        read only = No

for having samba working I need to change the winbind in smb.conf:
server services = -dns +winbind -winbindd
Comment 1 Stefan Metzmacher 2014-12-08 09:09:24 UTC

*** This bug has been marked as a duplicate of bug 10991 ***