Bug 10980 - Windows DPAPI fails when contacting Samba4 AD DC BackupKey server
Windows DPAPI fails when contacting Samba4 AD DC BackupKey server
Status: RESOLVED DUPLICATE of bug 11097
Product: Samba 4.1 and newer
Classification: Unclassified
All All
: P5 normal
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
Depends on: 11097
Blocks: 10077
  Show dependency treegraph
Reported: 2014-12-03 01:50 UTC by Kirin van der Veer
Modified: 2015-03-20 01:19 UTC (History)
2 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Kirin van der Veer 2014-12-03 01:50:31 UTC
The windows DPAPI fails after repeated user password change on Windows 7.
According to this bug report for UCS:
It is caused by the RSA modulus not being set to 2048 bits.

Samba developer Andrew Bartlett commented on the samba mailing list here:
That a patch would require a reviewer and testing to ensure against regressions.

This bug has been created to track when mainline samba implements a fix.
Comment 1 Andrew Bartlett 2015-02-16 04:55:10 UTC
The patches have been tidied up and are proposed for master and 4.2 in bug #11097
Comment 2 Björn Jacke 2015-03-04 21:45:34 UTC

*** This bug has been marked as a duplicate of bug 11097 ***