Bug 10965 - Missing eventfd prototype check in socket_wrapper for newer glibc
Missing eventfd prototype check in socket_wrapper for newer glibc
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Build
4.2.0rc2
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks: 10077
  Show dependency treegraph
 
Reported: 2014-11-26 09:15 UTC by Andreas Schneider
Modified: 2014-12-10 20:09 UTC (History)
2 users (show)

See Also:


Attachments
v4-2-test patch (991 bytes, patch)
2014-12-02 09:52 UTC, Andreas Schneider
no flags Details
additional v4-2-test patch (1.41 KB, patch)
2014-12-08 16:31 UTC, Andreas Schneider
no flags Details
Complete backport of socket_wrapper 1.1.2 to v4-2-test (82.98 KB, patch)
2014-12-08 16:46 UTC, Stefan Metzmacher
asn: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Schneider 2014-11-26 09:15:03 UTC
An eventfd prototype check in socket_wrapper for newer glibc versions is missing.
Comment 1 Andreas Schneider 2014-12-02 09:52:34 UTC
Created attachment 10475 [details]
v4-2-test patch
Comment 2 Andreas Schneider 2014-12-08 16:31:06 UTC
Created attachment 10504 [details]
additional v4-2-test patch
Comment 3 Stefan Metzmacher 2014-12-08 16:45:20 UTC
Comment on attachment 10475 [details]
v4-2-test patch

Shouldn't we backport all socket_wrapper 1.1.2 patches?
Comment 4 Stefan Metzmacher 2014-12-08 16:46:14 UTC
Created attachment 10505 [details]
Complete backport of socket_wrapper 1.1.2 to v4-2-test
Comment 5 Andreas Schneider 2014-12-08 16:49:04 UTC
Karolin, please add the complete backport patch to v4-2-test. Thanks!
Comment 6 Karolin Seeger 2014-12-09 20:35:38 UTC
(In reply to Andreas Schneider from comment #5)
Pushed to autobuild-v4-2-test.
Comment 7 Karolin Seeger 2014-12-10 20:09:26 UTC
(In reply to Karolin Seeger from comment #6)
Pushed to v4-2-test.
Closing out bug report.

Thanks!