Bug 10964 - No printers under Windows7; cannot install printer drivers
No printers under Windows7; cannot install printer drivers
Status: RESOLVED WORKSFORME
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Printing
4.2.0rc2
All All
: P5 normal
: ---
Assigned To: printing-maintainers
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-26 08:12 UTC by Johannes Gerken
Modified: 2016-11-16 16:45 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Gerken 2014-11-26 08:12:51 UTC
Hi,

I tried to install a printer driver or enumerate the printers with the aduc printer tool under a Windows7 client.

I get multiple error while adding a driver and the list of printers is empty.

I tried with CUPS and lpd. I used the tutorial from the wiki and other resources.

The bug ist with 4.2.0rc2 and git-master. I remember a similar bug in 4.1, something in a rpc pdu function?

Samba in debug mode dosen't give me any usefull information about this.

My setup: samba ADDC (no posix only ntacls) under Linux x64 3.17.4 and 50 Windows7 clients. 

I noticed, that I can't dissable/fork spoolssd, it's always "embedded" in testparm -v

I would appreciate any advise on debuging this bug, so I can post more information/patch.
Comment 1 Andreas Schneider 2016-11-10 11:11:43 UTC
This bug report doesn't contain any useful information. Please read:

https://www.samba.org/~asn/reporting_samba_bugs.txt
Comment 2 Andreas Schneider 2016-11-16 16:45:43 UTC
Please reopen if you can provide detailed information.