Bug 10957 - NT_STATUS_INVALID_SID on every administration command
NT_STATUS_INVALID_SID on every administration command
Status: RESOLVED DUPLICATE of bug 10720
Product: Samba 4.1 and newer
Classification: Unclassified
Component: DCE-RPCs and pipes
x64 Linux
: P5 normal
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2014-11-24 08:59 UTC by Benoit
Modified: 2014-11-25 00:56 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Benoit 2014-11-24 08:59:11 UTC
Any administration command sent via the linux command line to samba e.g.

net rpc info -UAdministrator

results in the following error : NT_STATUS_INVALID_SID

It's not possible to create users or put them in groups this way. The same error appears again and again. When trying to administer users with RSAT components, the message "RPC server not available".
Already tried to flush firewall, but it didn't help.
Impossible to create another user and put him as "domain admin".
"samba-tool dbcheck" has been done. No errors found.
There seem to be a problem with the "administrators" group SID.
Saw this here http://comments.gmane.org/gmane.network.samba.general/143263
Shares, roaming profile, etc are working fine. It just seems to be a matter of admin. Version 4.2.0rc2 but also on 4.3pre1
Comment 1 Andrew Bartlett 2014-11-25 00:56:03 UTC

*** This bug has been marked as a duplicate of bug 10720 ***