Bug 10899 - netbios name truncating doesn't work
netbios name truncating doesn't work
Status: RESOLVED DUPLICATE of bug 10896
Product: Samba 4.0
Classification: Unclassified
Component: Other
4.0.21
All All
: P5 normal
: ---
Assigned To: Jeremy Allison
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-28 07:53 UTC by Andreas Schneider
Modified: 2014-10-28 07:56 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Schneider 2014-10-28 07:53:26 UTC
In nmbd we try to truncate the netbios name if we try to register it.

with commit d546adeab54af123eff66cee61a487c88b6ba61b the behaviour of push_ascii_nstring() changed.

This change of behaviour creates a bug in register_name(). If we call push_ascii_nstring() on a netbios name longer than 15 chars we end up registering an empty string!

To reprocude this set the following variable in smb.conf and start nmbd:

  netbios name = XABCDEFGHIJKLMNOPQRSTUVWXYZ

X will be replaced by \0.
Comment 1 Andreas Schneider 2014-10-28 07:56:17 UTC

*** This bug has been marked as a duplicate of bug 10896 ***