Bug 1085 - smbd[11143]: INTERNAL ERROR: Signal 11 in pid 11143 (2.2.3a-12.3 for Debian)
smbd[11143]: INTERNAL ERROR: Signal 11 in pid 11143 (2.2.3a-12.3 for Debian)
Status: RESOLVED WONTFIX
Product: Samba 2.2
Classification: Unclassified
Component: File Services
2.2.3a
All Linux
: P3 normal
: ---
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-16 06:34 UTC by Bourdin Pierre
Modified: 2005-11-14 09:27 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bourdin Pierre 2004-02-16 06:34:55 UTC
Hi all,
I have remarked this today on my logfile:
<logfile>
Feb 16 13:33:07 priam kernel: smb_trans2_request: result=-54, setting invalid
Feb 16 13:33:08 priam kernel: smb_retry: successful, new pid=20259, generation=10
Feb 16 13:37:49 priam smbd[11144]: [2004/02/16 13:37:49, 0]
rpc_server/srv_netlog.c:api_net_sam_logon(206) 
Feb 16 13:37:49 priam smbd[11144]:   api_net_sam_logon: Failed to marshall
NET_R_SAM_LOGON. 
Feb 16 13:37:49 priam smbd[11144]: [2004/02/16 13:37:49, 0]
rpc_server/srv_pipe.c:api_rpcTNP(1200) 
Feb 16 13:37:49 priam smbd[11144]:   api_rpcTNP: api_netlog_rpc: NET_SAMLOGON
failed. 
Feb 16 13:37:49 priam smbd[11144]: [2004/02/16 13:37:49, 0]
rpc_server/srv_netlog.c:api_net_sam_logon(206) 
Feb 16 13:37:49 priam smbd[11144]:   api_net_sam_logon: Failed to marshall
NET_R_SAM_LOGON. 
Feb 16 13:37:49 priam smbd[11144]: [2004/02/16 13:37:49, 0]
rpc_server/srv_pipe.c:api_rpcTNP(1200) 
Feb 16 13:37:49 priam smbd[11144]:   api_rpcTNP: api_netlog_rpc: NET_SAMLOGON
failed. 
Feb 16 13:37:53 priam smbd[11143]: [2004/02/16 13:37:53, 0]
lib/fault.c:fault_report(38) 
Feb 16 13:37:53 priam smbd[11143]:  
=============================================================== 
Feb 16 13:37:53 priam smbd[11143]: [2004/02/16 13:37:53, 0]
lib/fault.c:fault_report(39) 
Feb 16 13:37:53 priam smbd[11143]:   INTERNAL ERROR: Signal 11 in pid 11143
(2.2.3a-12.3 for Debian) 
Feb 16 13:37:53 priam smbd[11143]:   Please read the file BUGS.txt in the
distribution 
Feb 16 13:37:53 priam smbd[11143]: [2004/02/16 13:37:53, 0]
lib/fault.c:fault_report(41) 
Feb 16 13:37:53 priam smbd[11143]:  
=============================================================== 
Feb 16 13:37:53 priam smbd[11143]: [2004/02/16 13:37:53, 0]
lib/util.c:smb_panic(1064) 
Feb 16 13:37:53 priam smbd[11143]:   PANIC: internal error 
Feb 16 13:37:53 priam smbd[11143]: 
Feb 16 13:37:53 priam smbd[11143]: [2004/02/16 13:37:53, 0]
lib/fault.c:fault_report(38) 
Feb 16 13:37:53 priam smbd[11143]:  
=============================================================== 
Feb 16 13:37:53 priam smbd[11143]: [2004/02/16 13:37:53, 0]
lib/fault.c:fault_report(39) 
Feb 16 13:37:53 priam smbd[11143]:   INTERNAL ERROR: Signal 11 in pid 11143
(2.2.3a-12.3 for Debian) 
Feb 16 13:37:53 priam smbd[11143]:   Please read the file BUGS.txt in the
distribution 
Feb 16 13:37:53 priam smbd[11143]: [2004/02/16 13:37:53, 0]
lib/fault.c:fault_report(41) 
Feb 16 13:37:53 priam smbd[11143]:  
=============================================================== 
Feb 16 13:37:53 priam smbd[11143]: [2004/02/16 13:37:53, 0]
lib/util.c:smb_panic(1064) 
Feb 16 13:37:53 priam smbd[11143]:   PANIC: internal error 
Feb 16 13:37:53 priam smbd[11143]: 
</logfile>

I have no idea what it is and how dangerous it could be ?

But I'am sad to say we had 2 Ooops (kernel panic) caused by smbd in the last
month...
(kernel was 2.4.19, and I'am running a 2.4.23 now...)
I could'nt save the console for the Ooops msg, but it was clearly smbd which was
responsible for the crash... 
This is why I'am submitting this bug report, even if it has nothing to do with ? 
I don't know.

Well we are running linux debian on an alpha 2100:
Linux priam 2.4.23 #1 SMP ven déc 12 14:51:17 CET 2003 alpha unknown
smbd: 
Version 2.2.3a-12.3 for Debian
The machine act as PDC. 
There are several shared directories phycally on a  Mylex DAC960PD PCI RAID
Controller.
Contact me if you need more info...
P.B.
Comment 1 Gerald (Jerry) Carter 2004-02-17 08:39:17 UTC
when a user-space application can cause the kernel to 
crash it is a kernel bug.

However, the crashes inside of smbd (as noted by 
the log files) are our bugs.  If you can reproduce this
against the latest 3.0 release, please refile the bug.  
There will be no more work on the 2.2 branch due to 
resource limitations.
Comment 2 Gerald (Jerry) Carter 2005-11-14 09:27:09 UTC
database cleanup