Bug 10754 - exception when running make pydoctor
exception when running make pydoctor
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Build
unspecified
All All
: P5 normal
: ---
Assigned To: Jelmer Vernooij
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-07-30 17:40 UTC by David Bear
Modified: 2014-11-01 15:47 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Bear 2014-07-30 17:40:44 UTC
When creating the python api docs I run 

make pydoctor

from my samba build directory.

Here is there error I get:

make pydoctor
WAF_MAKE=1 python ./buildtools/bin/waf pydoctor
Traceback (most recent call last):
  File "./buildtools/bin/waf", line 76, in <module>
    Scripting.prepare(t, cwd, VERSION, wafdir)
  File "/home/david/temp/samba/buildtools/wafadmin/Scripting.py", line 145, in prepare
    prepare_impl(t, cwd, ver, wafdir)
  File "/home/david/temp/samba/buildtools/wafadmin/Scripting.py", line 135, in prepare_impl
    main()
  File "/home/david/temp/samba/wscript", line 326, in main
    wildcard_main(wildcard_cmd)
  File "./buildtools/wafsamba/samba_wildcard.py", line 110, in wildcard_main
    fun(ctx)
  File "/home/david/temp/samba/wscript", line 256, in pydoctor
    bp, mpaths['tdb'], mpaths['ldb'], mpaths['talloc'], mpaths['ntdb'])
TypeError: not all arguments converted during string formatting
make: *** [pydoctor] Error 1
Comment 1 Jelmer Vernooij 2014-10-12 22:45:59 UTC
It looks like this was a regression introduced when we started using pydoctor.
Comment 2 Jelmer Vernooij 2014-10-12 22:46:22 UTC
Eh, it looks like this was a regression introduced when we added *ntdb* to the tree.
Comment 3 Jelmer Vernooij 2014-10-12 22:48:11 UTC
Eh, it looks like this was a regression introduced when we added *ntdb* to the tree.