Bug 10677 - external zlib broken after update to 3.1.1 on FreeBSD
external zlib broken after update to 3.1.1 on FreeBSD
Status: RESOLVED INVALID
Product: rsync
Classification: Unclassified
Component: core
3.1.1
x64 FreeBSD
: P5 normal
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-06-27 13:53 UTC by Emanuel Haupt
Modified: 2015-07-13 05:04 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Emanuel Haupt 2014-06-27 13:53:08 UTC
After updating the FreeBSD port from 3.1.0 to 3.1.1 external zlib support is broken:

--- output of regression test begins here ---
# 3.1.1
root@wiggles:/tmp/test # rm dst/*; rsync -z -avP src/. dst/
This rsync lacks old-style --compress due to its external zlib.  Try -zz.
Continuing without compression.

sending incremental file list
./
file1
    104,857,600 100%  316.36MB/s    0:00:00 (xfr#1, to-chk=2/4)
file2
    104,857,600 100%  154.32MB/s    0:00:00 (xfr#2, to-chk=1/4)
file3
    104,857,600 100%  107.64MB/s    0:00:00 (xfr#3, to-chk=0/4)

sent 314,649,797 bytes  received 76 bytes  209,766,582.00 bytes/sec
total size is 314,572,800  speedup is 1.00

root@wiggles:/tmp/test # rm dst/*; rsync -zz -avP src/ dst/
sending incremental file list
./
file1
    104,857,600 100%   16.57MB/s    0:00:06 (xfr#1, to-chk=2/4)
file2
    104,857,600 100%   16.37MB/s    0:00:06 (xfr#2, to-chk=1/4)
file3
    104,857,600 100%   16.36MB/s    0:00:06 (xfr#3, to-chk=0/4)

sent 314,752,131 bytes  received 76 bytes  17,013,632.81 bytes/sec
total size is 314,572,800  speedup is 1.00

# 3.1.1 with bundled ZLIB
root@wiggles:/tmp/test # rm dst/*; rsync -z -avP src/ dst/
sending incremental file list
./
file1
    104,857,600 100%   16.33MB/s    0:00:06 (xfr#1, to-chk=2/4)
file2
    104,857,600 100%   16.17MB/s    0:00:06 (xfr#2, to-chk=1/4)
file3
    104,857,600 100%   15.99MB/s    0:00:06 (xfr#3, to-chk=0/4)

sent 314,752,131 bytes  received 76 bytes  17,013,632.81 bytes/sec
total size is 314,572,800  speedup is 1.00


# 3.1.0_3
root@wiggles:/tmp/test # rm dst/*; rsync -z -avP src/. dst/
sending incremental file list
./
file1
    104,857,600 100%   16.92MB/s    0:00:05 (xfr#1, to-chk=2/4)
file2
    104,857,600 100%   14.72MB/s    0:00:06 (xfr#2, to-chk=1/4)
file3
    104,857,600 100%   14.99MB/s    0:00:06 (xfr#3, to-chk=0/4)

sent 314,752,131 bytes  received 76 bytes  17,013,632.81 bytes/sec
total size is 314,572,800  speedup is 1.00
--- output of regression test ends here ---

libz version:
http://svnweb.freebsd.org/base/stable/10/lib/libz/
Comment 1 Wayne Davison 2014-06-29 17:00:37 UTC
I tried to figure out what you think is broken, but I couldn't figure it out.  The -z option (as opposed to -zz) only works if you compile using the included zlib, so use that if you want the backward-compatible -z functionality. Was there something else?  The file sizes all seem remarkably uncompressible in your output, but that's consistent across the versions you list, and my own testing shows proper compressing using -zz and some compressible sources I tried.
Comment 2 Emanuel Haupt 2014-06-30 07:30:49 UTC
Sorry about the confusion, I should have been more clear. The FreeBSD version is built with --with-included-zlib=no by default.

After reading the man page entry again about -z, --compress there seems to be a confusion about how to use -z.

I was prompted about this by a user who's seen the following warning which didn't appear in the previous version while using -z:

--- warning begins here ---
This rsync lacks old-style --compress due to its external zlib.  Try -zz.
Continuing without compression.
--- warning ends here ---

Even though this warning is new it seems like -zz should have been used all along.