Bug 1067 - No printing under WinXP with samba 3.0.2, - 2.2.8a is ok.
No printing under WinXP with samba 3.0.2, - 2.2.8a is ok.
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: Printing
3.0.2
All Linux
: P3 major
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-12 03:54 UTC by Thomas Steudten
Modified: 2005-11-14 09:28 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Steudten 2004-02-12 03:54:30 UTC
Hi
samba 3.0.2 rebuild from source rpm under linux/alpha - no major bugs, some
warnings. Printing from WinXP with fineprint blocks. Sometimes printing
direct to the printer (printer properties under winxp) gives the testpage, after
this it blocks. Printing is in general impossible. 
I´ve no time at the moment to examine the problem, because i need the printing,
so i downgrade to 2.2.8a.
I got this from syslog/ log (BTW: For me it seems that the logging goes always
to the syslog, not only to the logs)

smbd[18303]: [2004/02/12 11:30:55, 0, effective(500, 500), real(500, 0)]
tdb/tdbutil.c:tdb_log(724)
smbd[18303]:   tdb(/var/lib/samba/printing/6mp.tdb): tdb_oob len 1111638598
beyond eof at 24576
smbd[18303]: [2004/02/12 11:30:55, 0, effective(500, 500), real(500, 0)]
tdb/tdbutil.c:tdb_log(724)
smbd[18303]:   tdb(/var/lib/samba/printing/6mp.tdb): remove_from_freelist: not
on list at off=21916
smbd[18303]: [2004/02/12 11:30:55, 0, effective(500, 500), real(500, 0)]
tdb/tdbutil.c:tdb_log(724)
smbd[18303]:   tdb(/var/lib/samba/printing/6mp.tdb): tdb_free: right free failed
at 21916
smbd[18303]: [2004/02/12 11:30:56, 0, effective(500, 500), real(500, 0)]
smbd/connection.c:register_message_flags(220)
smbd[18303]:   register_message_flags: tdb_fetch failed
smbd[18303]: [2004/02/12 11:30:56, 0, effective(500, 500), real(500, 0)]
smbd/connection.c:register_message_flags(220)
smbd[18303]:   register_message_flags: tdb_fetch failed
smbd[18303]: [2004/02/12 11:30:56, 0, effective(500, 500), real(500, 0)]
smbd/connection.c:register_message_flags(220)
smbd[18303]:   register_message_flags: tdb_fetch failed
smbd[18303]: [2004/02/12 11:30:57, 0, effective(500, 500), real(500, 0)]
tdb/tdbutil.c:tdb_log(724)
smbd[18303]:   tdb(/var/lib/samba/printing/6mp.tdb): tdb_oob len 1111638598
beyond eof at 24576
smbd[18303]: [2004/02/12 11:30:57, 0, effective(500, 500), real(500, 0)]
tdb/tdbutil.c:tdb_log(724)
smbd[18303]:   tdb(/var/lib/samba/printing/6mp.tdb): remove_from_freelist: not
on list at off=21916
smbd[18303]: [2004/02/12 11:30:57, 0, effective(500, 500), real(500, 0)]
tdb/tdbutil.c:tdb_log(724)
smbd[18303]:   tdb(/var/lib/samba/printing/6mp.tdb): tdb_free: right free failed
at 21916
smbd[18303]: [2004/02/12 11:30:57, 0, effective(500, 500), real(500, 0)]
tdb/tdbutil.c:tdb_log(724)
smbd[18303]:   tdb(/var/lib/samba/printing/6mp.tdb): rec_free_read bad magic
0x42424242 at offset=22964
smbd[18303]: [2004/02/12 11:31:28, 0, effective(0, 0), real(0, 0)]
tdb/tdbutil.c:tdb_log(724)
smbd[18303]:   tdb(/var/lib/samba/printing/6mp.tdb): tdb_oob len 1111638598
beyond eof at 24576
smbd[18303]: [2004/02/12 11:31:28, 0, effective(0, 0), real(0, 0)]
tdb/tdbutil.c:tdb_log(724)
smbd[18303]:   tdb(/var/lib/samba/printing/6mp.tdb): remove_from_freelist: not
on list at off=21916
smbd[18303]: [2004/02/12 11:31:28, 0, effective(0, 0), real(0, 0)]
tdb/tdbutil.c:tdb_log(724)
smbd[18303]:   tdb(/var/lib/samba/printing/6mp.tdb): tdb_free: right free failed
at 21916
smbd[18303]: [2004/02/12 11:31:56, 0, effective(500, 500), real(500, 0)]
smbd/connection.c:register_message_flags(220)
smbd[18303]:   register_message_flags: tdb_fetch failed
nmbd[18226]: [2004/02/12 11:35:47, 0, effective(0, 0), real(0, 0)]
nmbd/nmbd.c:terminate(54)

If you need more informations, please give feedback.
Comment 1 Gerald (Jerry) Carter 2004-03-22 13:20:35 UTC
please try either (a) the patches in bug 1147 and bug 1007, 
or (b) Samba 3.0.3pre1.  Thanks.  

If you are not in a position to continue to reproduce this 
due to having moved thsi production server back to 2.2.8a
I can't really move forward I don't think.
Comment 2 Gerald (Jerry) Carter 2004-04-22 20:18:08 UTC
no feedback.  closing.
Comment 3 Gerald (Jerry) Carter 2005-11-14 09:28:13 UTC
database cleanup