Bug 10666 - Recycle bin doesn't work
Recycle bin doesn't work
Status: RESOLVED DUPLICATE of bug 8637
Product: Samba 4.1 and newer
Classification: Unclassified
Component: VFS Modules
unspecified
All All
: P5 major
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-06-20 23:19 UTC by CurlyMoo
Modified: 2014-10-13 10:46 UTC (History)
1 user (show)

See Also:


Attachments
Delete log as requested in the developers mailinglist. (46.05 KB, text/x-log)
2014-06-20 23:19 UTC, CurlyMoo
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description CurlyMoo 2014-06-20 23:19:36 UTC
Created attachment 10044 [details]
Delete log as requested in the developers mailinglist.

I'm currently have a ZFS NAS setup similar to this:

/data/user1/Work
/data/user1/Hobby
/data/user2/Work
/data/user2/Hobby
/data/recycle/user1
/data/recycle/user2

All are separate ZFS filesystems.

My samba configuration (relevant part) looks like this:

[data]
    path = /data/%U
    vfs objects = recycle
    recycle:repository = /data/recycle/%U
    recycle:keeptree = yes
    recycle:versions = yes
    recycle:touch = yes
    recycle:maxsize = 0

[recycle]
    path = /data/recycle/%U

When running a default manually compiled Samba 3.5.11, this all works without issues. All files that are removed from any folder in /data/%U/* are moved to the /data/recycle/%U folder. However, this ONLY works with Samba 3.5.11. In any later version (and I believe also previous versions) this doesn't work anymore.
Comment 1 CurlyMoo 2014-06-24 07:00:48 UTC
Was solved by adding the crossrename vfs module. However, as posted in the other thread reporting the same bug: where is the documentation on this?!?

*** This bug has been marked as a duplicate of bug 8637 ***