Bug 10664 - Samba Printing using local port print in IPV6 environment from Windows7 client machine fails
Samba Printing using local port print in IPV6 environment from Windows7 clien...
Status: RESOLVED DUPLICATE of bug 10561
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Printing
4.1.4
All All
: P5 normal
: ---
Assigned To: printing-maintainers
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-06-18 15:11 UTC by shivappa
Modified: 2014-06-18 15:40 UTC (History)
0 users

See Also:


Attachments
samba_Ipv6_Win7_Print_fails (1.32 MB, application/octet-stream)
2014-06-18 15:11 UTC, shivappa
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description shivappa 2014-06-18 15:11:34 UTC
Created attachment 10041 [details]
samba_Ipv6_Win7_Print_fails

Hi Team,

We are running samba-4.1.4 on fedora-OS and found issue on ipv6 printing.
The detailed description is as below.

IPV4:
1.Installed the printer from Windows7 using local-port print(\\ipv4.address\print).
2.Printer installation succeeded.
3.Test page spooled and job-success.

IPV6:(issue present from 3.6.x)
1.Installed the printer from Windows7 using local-port print(\\ipv6.address\print).
2.Printer installation succeeds.
3.Test page spooled but no job-success.
4.Got  "print_job_end: canceling spool of /var/spool/samba/smbprn.4cLprE (zero length)" error in logfile.

Observations on the issue:
smbprn files present in /var/spool/samba/ are having proper data(header , EOF and all).

smbd_smb2_request_dispatch: opcode[SMB2_OP_CREATE] is happening many times.Then after opcode[SMB2_OP_WRITE] is calling, by that time the new smbprn files are created and having zero length, so job not gets succeed. 

Please help to resolve the issue.

I can provide more debugging details, please let me know how I can help.

Best Regards,
Shivappa
Comment 1 David Disseldorp 2014-06-18 15:40:11 UTC

*** This bug has been marked as a duplicate of bug 10561 ***