Bug 1062 - [patch] wbinfo -N causes winbind to segfault
[patch] wbinfo -N causes winbind to segfault
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.0
All Linux
: P3 major
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-11 12:55 UTC by Andrew Esh
Modified: 2009-06-06 16:00 UTC (History)
0 users

See Also:


Attachments
Patch winbindd_wins.c to fix temp addr buf problem (1.91 KB, patch)
2004-02-11 12:58 UTC, Andrew Esh
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Esh 2004-02-11 12:55:11 UTC
While doing wbinfo -N requests, winbindd crashed into gdb. Fixed the bug, will 
attach a patch.
Comment 1 Andrew Esh 2004-02-11 12:58:13 UTC
Created attachment 397 [details]
Patch winbindd_wins.c to fix temp addr buf problem

This patch changes the use of a char * to an fstrcpy into a local static
buffer, when calling inet_ntoa. Later in the old code, it was found that the
address pointed to by "addr" was out of range, implying that another ntoa call
had overwritten it.
Comment 2 Gerald (Jerry) Carter 2004-03-18 07:06:06 UTC
moving to 3.0
Comment 3 Gerald (Jerry) Carter 2004-03-18 07:12:29 UTC
resetting component
Comment 4 Volker Lendecke 2009-06-06 16:00:27 UTC
Can't reproduce any problem with 3.2 and master. Please re-open if it's still an issue with current code.

Thanks,

Volker