Bug 10591 - Lock order violation
Lock order violation
Status: RESOLVED DUPLICATE of bug 10564
Product: Samba 4.1 and newer
Classification: Unclassified
Component: File services
4.1.6
All FreeBSD
: P5 normal
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-05-05 19:17 UTC by Josh Paetzel
Modified: 2014-05-05 20:08 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Josh Paetzel 2014-05-05 19:17:36 UTC
https://bugs.freenas.org/issues/4933

May 5 12:50:16 freenas smbd16534: [2014/05/05 12:50:16.191562, 0] ../lib/dbwrap/dbwrap.c:193(dbwrap_check_lock_order)
May 5 12:50:16 freenas smbd16534: Lock order violation: Trying /var/db/samba4/smbXsrv_open_global.tdb at 1 while /var/db/samba4/locking.tdb at 1 is locked
May 5 12:50:16 freenas smbd16534: [2014/05/05 12:50:16.191854, 0] ../lib/dbwrap/dbwrap.c:133(debug_lock_order)
May 5 12:50:16 freenas smbd16534: lock order: 1:/var/db/samba4/locking.tdb 2:<none> 3:<none>
May 5 12:50:16 freenas smbd16534: [2014/05/05 12:50:16.191984, 0] ../source3/lib/util.c:785(smb_panic_s3)
May 5 12:50:16 freenas smbd16534: PANIC (pid 16534): invalid lock_order
May 5 12:50:16 freenas kernel: pid 16534 (smbd), uid 21105: exited on signal 10
May 5 12:50:59 freenas smbd18298: [2014/05/05 12:50:59.648246, 0] ../lib/dbwrap/dbwrap.c:193(dbwrap_check_lock_order)
May 5 12:50:59 freenas smbd18298: Lock order violation: Trying /var/db/samba4/smbXsrv_open_global.tdb at 1 while /var/db/samba4/locking.tdb at 1 is locked
May 5 12:50:59 freenas smbd18298: [2014/05/05 12:50:59.648538, 0] ../lib/dbwrap/dbwrap.c:133(debug_lock_order)
May 5 12:50:59 freenas smbd18298: lock order: 1:/var/db/samba4/locking.tdb 2:<none> 3:<none>
May 5 12:50:59 freenas smbd18298: [2014/05/05 12:50:59.648661, 0] ../source3/lib/util.c:785(smb_panic_s3)
May 5 12:50:59 freenas kernel: pid 18298 (smbd), uid 21105: exited on signal 10
May 5 12:50:59 freenas smbd18298: PANIC (pid 18298): invalid lock_order
May 5 12:51:12 freenas smbd18300: [2014/05/05 12:51:12.730959, 0] ../lib/dbwrap/dbwrap.c:193(dbwrap_check_lock_order)
May 5 12:51:12 freenas smbd18300: Lock order violation: Trying /var/db/samba4/smbXsrv_open_global.tdb at 1 while /var/db/samba4/locking.tdb at 1 is locked
May 5 12:51:12 freenas smbd18300: [2014/05/05 12:51:12.731270, 0] ../lib/dbwrap/dbwrap.c:133(debug_lock_order)
May 5 12:51:12 freenas smbd18300: lock order: 1:/var/db/samba4/locking.tdb 2:<none> 3:<none>
May 5 12:51:12 freenas smbd18300: [2014/05/05 12:51:12.731395, 0] ../source3/lib/util.c:785(smb_panic_s3)
May 5 12:51:12 freenas smbd18300: PANIC (pid 18300): invalid lock_order
May 5 12:51:12 freenas kernel: pid 18300 (smbd), uid 21105: exited on signal 10
May 5 12:52:00 freenas smbd18301: [2014/05/05 12:52:00.223945, 0] ../lib/dbwrap/dbwrap.c:193(dbwrap_check_lock_order)
May 5 12:52:00 freenas smbd18301: Lock order violation: Trying /var/db/samba4/smbXsrv_open_global.tdb at 1 while /var/db/samba4/locking.tdb at 1 is locked
May 5 12:52:00 freenas smbd18301: [2014/05/05 12:52:00.224255, 0] ../lib/dbwrap/dbwrap.c:133(debug_lock_order)
May 5 12:52:00 freenas smbd18301: lock order: 1:/var/db/samba4/locking.tdb 2:<none> 3:<none>
May 5 12:52:00 freenas smbd18301: [2014/05/05 12:52:00.224384, 0] ../source3/lib/util.c:785(smb_panic_s3)
May 5 12:52:00 freenas smbd18301: PANIC (pid 18301): invalid lock_order
May 5 12:52:00 freenas kernel: pid 18301 (smbd), uid 21105: exited on signal 10

I have requested the smb.conf and debug logs.
Comment 1 Jeremy Allison 2014-05-05 20:08:56 UTC
Almost certainly a duplicate of 10564.

https://bugzilla.samba.org/show_bug.cgi?id=10564

Patch has been posted to that bug, already applied to master
and once +1'ed by Volker will be merged into 4.0.next, 4.1.next.

If you want to give this fix to the customer to test, please feel free to do so.

Sorry for the problem.

Jeremy.

*** This bug has been marked as a duplicate of bug 10564 ***