Bug 10571 - Fails to work from machine to machine after upgrade to Kubuntu 14.01
Fails to work from machine to machine after upgrade to Kubuntu 14.01
Status: RESOLVED DUPLICATE of bug 10532
Product: rsync
Classification: Unclassified
Component: core
3.1.0
All All
: P5 normal
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-28 07:07 UTC by John Jacq
Modified: 2014-04-29 17:16 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Jacq 2014-04-28 07:07:15 UTC
After an upgrade of Kubuntu yesterday, all my backups fail.

Here is a typical command with rsync's error messages:

It is followed with me opening a secure shell to sirius to demonstrate that it's not a Hostkey or private/public key issue, all the private keys have been loaded in the agent so passwords/passphrases are not necessary

Then I used scp to copy a file across

Finally I add the version of rsync that is installed.

John

-------------------------------------------------------------------------------
jjjacq@aldebaran:~$ rsync -e ssh -r -avz /home/jjjacq/Documents/web/ sirius:web/
protocol version mismatch - is your shell clean?
(see the rsync man page for an explanation)
rsync error: protocol incompatibility (code 2) at compat.c(62)
rsync: connection unexpectedly closed (0 bytes received so far) [sender]
rsync error: error in rsync protocol data stream (code 12) at io.c(226) [sender=3.1.0]
jjjacq@aldebaran:~$ 
jjjacq@aldebaran:~$ ssh sirius
Last login: Mon Apr 28 16:46:08 2014 from 192.168.1.11
Linux 2.4.22.

All that glitters is not gold; all that wander are not lost.

sirius ~$ 
sirius ~$ logout
Connection to sirius closed.
jjjacq@aldebaran:~$ scp john.asc sirius:tmp/
john.asc                                               100% 1337     1.3KB/s   00:00    
jjjacq@aldebaran:~$ rsync --version
rsync  version 3.1.0  protocol version 31

-----------------------------------------------------------------------------
Comment 1 Wayne Davison 2014-04-29 17:16:07 UTC

*** This bug has been marked as a duplicate of bug 10532 ***