Bug 10497 - rsync fails to sync certain sparse file combinations with compression
rsync fails to sync certain sparse file combinations with compression
Status: RESOLVED DUPLICATE of bug 10372
Product: rsync
Classification: Unclassified
Component: core
3.1.1
All All
: P5 normal
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-14 18:07 UTC by Orion Poplawski
Modified: 2014-03-14 23:26 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Orion Poplawski 2014-03-14 18:07:15 UTC
I am finding that rsync is failing to sync up certain combinations (sender and receiver) of sparse files when using compression.  With 3.1.1pre1 I just see:

# rsync -axHS -z --msgs2stderr /export/images/Fedora-Minimal-armhfp-20-1-sda.raw barry:/export/tmp/
rsync: [sender] write error: Broken pipe (32)
rsync error: error in rsync protocol data stream (code 12) at io.c(820) [sender=3.1.1pre1]

With some older versions I can see the server fail with "inflate returned -3 (0 bytes)", so it appears that the compressed stream is getting corrupted somehow.

strace of the server with 3.1.1pre1 just shows it quitting:

[pid  2216] write(3, "L\305\254\16_\314\364\307<\207.\355\241#\306\24\274\343\33]1K\274\313(\2560^z\227N\223\350\246\203I\302(\363U!\324\267yVlc\251\33f(-\245\322\306\231n\320\2643\261|\24\324\\(ZV\341\n\21.+\352}\266\236\350\210\303\"I\227\206\360\301\260\263i\222C/\374\360\203\350\200\231\377="..., 504) = 504
[pid  2216] select(1, [0], [], [0], {60, 0}) = 1 (in [0], left {59, 999998})
[pid  2216] read(0, "\353\202\26\3753\262.8\246n\211\367\1~c\32\343\361\262'\242\326\275W\232\34\v_\35\n\334\23\203\240\226\t\201g\3174\216\363\362\370'\34\374\331\304\345\213\4p\236\321\275u\236\211\234\347\263\210\262\367\262\334\374\257v=\16\366\237\354[k[\252\237&^P\331\267\6\265T\247\222\307\216\357\207\362H\254\237]\277"..., 16377) = 16377
[pid  2216] rt_sigaction(SIGUSR1, {SIG_IGN, [], SA_RESTORER, 0x7fb50326fcb0}, NULL, 8) = 0
[pid  2216] rt_sigaction(SIGUSR2, {SIG_IGN, [], SA_RESTORER, 0x7fb50326fcb0}, NULL, 8) = 0
[pid  2216] close(1)                    = 0
[pid  2216] close(3)                    = 0
[pid  2216] unlink(".Fedora-Minimal-armhfp-20-1-sda.raw.0gP5f5") = 0
[pid  2216] select(0, NULL, NULL, NULL, {0, 100000}) = 0 (Timeout)
[pid  2216] exit_group(12)              = ?
[pid  2216] +++ exited with 12 +++

Interestingly, this appears to be one of those situations in 3.1.0 fixed in 3.1.1pre1 where the temp file would be left around.
Comment 1 Wayne Davison 2014-03-14 23:26:51 UTC
I'd imagine that this is a duplicate of 10372.  See that bug for some suggestions.

*** This bug has been marked as a duplicate of bug 10372 ***