Bug 10482 - Error on printer driver assignment
Error on printer driver assignment
Status: NEW
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Printing
4.1.5
x64 Linux
: P5 normal
: ---
Assigned To: David Disseldorp
Samba QA Contact
: iolab
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-02 17:00 UTC by Marc Muehlfeld
Modified: 2016-11-16 17:04 UTC (History)
2 users (show)

See Also:


Attachments
Level 10 debug logs (849.68 KB, application/x-bzip2)
2014-03-02 17:00 UTC, Marc Muehlfeld
no flags Details
Error Screenshot (60.91 KB, image/png)
2014-03-02 17:00 UTC, Marc Muehlfeld
no flags Details
Log file (3.56 MB, application/x-gzip)
2016-08-26 00:46 UTC, Marc Muehlfeld
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Muehlfeld 2014-03-02 17:00:03 UTC
Created attachment 9741 [details]
Level 10 debug logs

If you try to assign a printer driver to a printer on Windows, like described in the Wiki

https://wiki.samba.org/index.php/Samba_as_a_print_server#Associating_a_shared_printer_with_a_driver_and_preconfiguring

you receive an error: "Printer settings could not be saved. Operation could not be completed (error 0x0000007a)."

I have tested the following three different drivers on Win7 64-Bit and all bring this error, what makes me thing, that it's not driver specific.
- Sharp MX2600n PS 1212a
- HP Universal Driver PS 5.8.0.17508
- Samsung Universal Printer Driver

The error seems only to appear on the first assignment. If you change the driver on a device that has already one assigned, the error does not appear.

Even if the error comes up, it seems that the driver is assigned correctly. If you reopen the printer properties, all driver specific stuff is shows correctly.

I saw this error on Win7 64-Bit (haven't tested other versions).

Find attached a level 10 debug log of the assignment of an driver.
Comment 1 Marc Muehlfeld 2014-03-02 17:00:23 UTC
Created attachment 9742 [details]
Error Screenshot
Comment 2 David Disseldorp 2014-03-04 19:00:43 UTC
As always, thanks for your report Marc!

The 0x0000007a error is likely due to an ERROR_INSUFFICIENT_BUFFER response sent by Samba. Samba sends such a response when the client sends a request with an insufficient response buffer size.

I'll see whether I can reproduce this locally.
Comment 3 Marc Muehlfeld 2014-03-04 19:08:55 UTC
Let me know if there's anything more I can provide to fix this problem.
Comment 4 Andreas Schneider 2014-04-04 13:11:10 UTC
Is it possible that this is fixed, when we fixed the DCERPC fragment issue? Can you test v4-1-test (will be fixed in 4.1.7).
Comment 5 Marc Muehlfeld 2014-04-04 18:34:37 UTC
(In reply to comment #4)
> Is it possible that this is fixed, when we fixed the DCERPC fragment issue? Can
> you test v4-1-test (will be fixed in 4.1.7).

I did a

# git clone http://gitweb.samba.org/samba.git v4-1-test

and got version 4.2.0pre1-GIT-fc4845f. Is this correct?


I tried that version and the issue is still there.
Comment 6 David Disseldorp 2014-11-06 12:48:48 UTC
I can reproduce this using a Windows Server 2008 client against an up to date Samba 4.1 server.
Comment 7 Marc Muehlfeld 2015-03-05 14:48:34 UTC
Hello David, hello Andreas,

I wanted to give a feedback on this bug report: Today I installed a new printer and the problem still exists in 4.1.17.
Comment 8 David Disseldorp 2015-03-05 14:50:46 UTC
Unfortunately I don't have time to look at this at the moment. Will hopefully find some spare cycles soon.
Comment 9 Marc Muehlfeld 2016-08-26 00:46:01 UTC
Created attachment 12408 [details]
Log file

I tried this with Samba 4.5.0rc2 and Windows 8.1:
> Printer settings could not be saved.
> The data area passed to a system call is too small.

I could not test this on Win7 and Win10, because on these OS, printmanagement.msc currently does not work (see Bug #11280).


I've attached an updated level 10 debug log file from my test on 4.5.0rc2 and Win 8.1.



Btw: The new link to the Wiki page describing the steps is:
https://wiki.samba.org/index.php/Configuring_Point%27n%27Print_automatic_printer_driver_deployment#Associating_a_shared_printer_with_a_driver_and_pre-configuration
Comment 10 Andreas Schneider 2016-11-16 15:54:46 UTC
We looked into this and we can't fix that right now. Need to investigate in a IOlab.