Bug 10456 - Run path not set on Solaris
Run path not set on Solaris
Status: RESOLVED DUPLICATE of bug 10112
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Build
4.1.4
x86 Solaris
: P5 normal
: ---
Assigned To: Björn Jacke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-19 19:13 UTC by Tom Schulz
Modified: 2014-02-24 15:15 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Schulz 2014-02-19 19:13:52 UTC
Building Samba 4.1.4 on a Solaris 10 i386 box. The run path is not set correctly.
Configure concludes that a run path can not be set. The test in configure is:

['/opt/local/bin/gcc', 'default/main_2.o', '-o',
'/home/projects/tools/samba/samba-4.1.4.i386gcc/bin/.conf_check_0/testbuild/default/prog1',
'-R/opt/local/samba4/lib:/opt/local/samba4/lib/private',
'-Wl,-rpath,/home/projects/tools/samba/samba-4.1.4.i386gcc/bin/.conf_check_0/testbuild/default/libdir',
'-Ldefault/libdir', '-Wl,-Bdynamic', '-llib1']

The part with '-R/opt/local...' is correct. The part with 
'-Wl,-rpath,/home/projects/...' will cause an error as the Solaris linker does not understand that.
If you replace '-Wl,-rpath,' with '-R' than this test should pass.
Comment 1 Björn Jacke 2014-02-20 10:45:13 UTC

*** This bug has been marked as a duplicate of bug 10112 ***
Comment 2 Tom Schulz 2014-02-24 15:15:59 UTC
I know that this bug is closed, but to prevent anyone reading this from becoming confused, I should mention that the '-R/opt/local/samba4/lib...' that shows up in the test run by configure is due to my specifying that with the LDFLAGS environmental variable as follows:

#! /bin/sh
LDFLAGS="-R/opt/local/samba4/lib:/opt/local/samba4/lib/private" \
./configure configure  --prefix=/opt/local/samba4