Bug 10408 - smbd panics when logging in from Windows 8.1 client
smbd panics when logging in from Windows 8.1 client
Status: RESOLVED DUPLICATE of bug 10415
Product: Samba 4.0
Classification: Unclassified
Component: File services
4.0.14
All All
: P5 normal
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-31 01:53 UTC by Justin Maggard
Modified: 2014-03-11 21:02 UTC (History)
2 users (show)

See Also:


Attachments
gdb bt full (4.51 KB, text/plain)
2014-01-31 01:53 UTC, Justin Maggard
no flags Details
smbd debug level 10 log (1.56 MB, application/octet-stream)
2014-01-31 01:53 UTC, Justin Maggard
no flags Details
Wireshark capture (33.60 KB, application/octet-stream)
2014-01-31 01:54 UTC, Justin Maggard
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Maggard 2014-01-31 01:53:08 UTC
Created attachment 9626 [details]
gdb bt full

Using a Windows 8.1 client, specifically using the new default Microsoft account login, logging into a non-guest Samba share eventually results in a crash due to an invalid free in talloc.
Comment 1 Justin Maggard 2014-01-31 01:53:53 UTC
Created attachment 9627 [details]
smbd debug level 10 log
Comment 2 Justin Maggard 2014-01-31 01:54:22 UTC
Created attachment 9628 [details]
Wireshark capture
Comment 3 Volker Lendecke 2014-02-19 07:22:00 UTC
Can this be a dup of bug 10415? Can you try the patches from there?
Comment 4 Justin Maggard 2014-02-19 21:17:02 UTC
Yes, that takes care of it for me with older talloc.  Interestingly I had updated to talloc 2.1.0 and never saw the panic again after that.
Comment 5 Justin Maggard 2014-03-11 21:02:11 UTC

*** This bug has been marked as a duplicate of bug 10415 ***