Bug 104 - smbtar can't handle files >=8GB properly
smbtar can't handle files >=8GB properly
Status: RESOLVED DUPLICATE of bug 102
Product: Samba 2.2
Classification: Unclassified
Component: smbclient
2.2.8a
All Linux
: P2 major
: ---
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-21 06:33 UTC by Dragan Krnic
Modified: 2005-11-14 09:27 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dragan Krnic 2003-05-21 06:33:06 UTC
smbclient's built-in tar feature lists the size modulo 8 GB. It effectively 
truncates the size from left if it is >=8GB. For example, a  file 
14,570,219,438 bytes big (octal 154434763656) gets listed as
 5,980,284,846 bytes big (octal 54434763656).

The good news is that it puts all 14+ GBs on the tape but the tar can only
recover those cca. 6 GB listed, and complain about "obsolescent base-64 
headers".

As of GNU-tar 1.13.25 (on my SuSE 8.2) the correct way to list size of files 
greater than 11 octal digits is to put binary long 0x80000000 in the first 4 
bytes of the field and a binary long long size in the remaining 8 bytes, 
trailing '\0' be damned. Although I didn't find any documentation to that
effect, this is how it works.
Comment 1 Tim Potter 2003-05-22 18:32:41 UTC

*** This bug has been marked as a duplicate of 102 ***
Comment 2 Gerald (Jerry) Carter 2005-11-14 09:27:16 UTC
database cleanup