Bug 10397 - ERROR: samba tcp port 445, is not responding (log.ctdb)
ERROR: samba tcp port 445, is not responding (log.ctdb)
Status: RESOLVED INVALID
Product: CTDB 2.5.x or older
Classification: Unclassified
Component: ctdb
unspecified
x64 Linux
: P5 normal
: ---
Assigned To: Amitay Isaacs
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-22 20:08 UTC by Ivan Radenkovic
Modified: 2016-09-12 08:58 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Radenkovic 2014-01-22 20:08:26 UTC
i'm getting this error in CTDB log:
ERROR: samba tcp port 445, is not responding

it's strange because windows (xp & 7) workstation can connect to both nodes on my cluster (active/active configuration using drbd and gfs2). i didn't noticed this error before and i can not recall i have changed anything to make this happened. first it shows up on one node and later same day on other.

i forced iptables service to stop, but it didn't help.

samba is actually listening on port 445 (on both nodes):

[root@smb1 ~]# netstat -tulpn | egrep "samba|smbd|nmbd|winbind"
tcp        0      0 0.0.0.0:139                 0.0.0.0:*                   LISTEN      2270/smbd           
tcp        0      0 0.0.0.0:445                 0.0.0.0:*                   LISTEN      2270/smbd           
tcp        0      0 :::139                      :::*                        LISTEN      2270/smbd           
tcp        0      0 :::445                      :::*                        LISTEN      2270/smbd     

[root@smb1 ~]# service ctdb status
Checking for ctdbd service: 
Number of nodes:2
pnn:0 192.168.1.131    UNHEALTHY (THIS NODE)
pnn:1 192.168.1.130    UNHEALTHY
Generation:394048708
Size:2
hash:0 lmaster:0
hash:1 lmaster:1
Recovery mode:NORMAL (0)
Recovery master:1

[root@smb1 ~]# smbd -V
Version 4.0.0rc4

[root@smb1 ~]# cat /etc/sysconfig/ctdb
 CTDB_RECOVERY_LOCK="/clusterdata/ctdb.lock"
 CTDB_PUBLIC_INTERFACE=eth0
 CTDB_PUBLIC_ADDRESSES=/etc/ctdb/public_addresses
 CTDB_MANAGES_SAMBA=yes
 ulimit -n 10000
 CTDB_NODES=/etc/ctdb/nodes
 CTDB_LOGFILE=/var/log/log.ctdb
 CTDB_DEBUGLEVEL=2
 CTDB_PUBLIC_NETWORK="192.168.1.0/24"
 CTDB_PUBLIC_GATEWAY="192.168.1.1"

[root@smb1 ~]# ctdb scriptstatus
12 scripts were executed last monitor cycle
00.ctdb              Status:OK    Duration:0.008 Wed Jan 22 20:51:29 2014
01.reclock           Status:OK    Duration:0.019 Wed Jan 22 20:51:29 2014
10.interface         Status:OK    Duration:0.028 Wed Jan 22 20:51:29 2014
11.routing           Status:OK    Duration:0.007 Wed Jan 22 20:51:29 2014
11.natgw             Status:OK    Duration:0.007 Wed Jan 22 20:51:29 2014
11.route             Status:OK    Duration:0.007 Wed Jan 22 20:51:29 2014
13.per_ip_routing    Status:OK    Duration:0.007 Wed Jan 22 20:51:29 2014
20.multipathd        Status:DISABLED    
31.clamd             Status:DISABLED    
40.vsftpd            Status:OK    Duration:0.008 Wed Jan 22 20:51:29 2014
41.httpd             Status:OK    Duration:0.008 Wed Jan 22 20:51:29 2014
50.samba             Status:ERROR    Duration:0.040 Wed Jan 22 20:51:29 2014
   OUTPUT:ERROR: samba tcp port 445, is not responding

There were nothing on google, I'm desperate... Even this manpage contain the same samba related error http://ctdb.samba.org/manpages/ctdb.1.html
Comment 1 Amitay Isaacs 2014-08-20 12:55:01 UTC
What is the version of CTDB?

What's the output of following command?

  sh -x /etc/ctdb/events.d/50.samba monitor
Comment 2 Martin Schwenke 2016-09-12 08:58:50 UTC
Required information never provided, so unable to find root cause.