Bug 10341 - access from old MSClinet don't work anymore
access from old MSClinet don't work anymore
Status: RESOLVED DUPLICATE of bug 2662
Product: Samba 4.1 and newer
Classification: Unclassified
Component: File services
4.1.3
x64 Other
: P5 normal
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-20 19:58 UTC by Christian Gosslar
Modified: 2014-01-10 03:07 UTC (History)
0 users

See Also:


Attachments
smb log (904.94 KB, application/octet-stream)
2013-12-20 19:58 UTC, Christian Gosslar
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Gosslar 2013-12-20 19:58:29 UTC
Created attachment 9542 [details]
smb log

The old DOS Client MSClinet can see the shares and can login, but if I try to list a directory, the first directory is displayed in e endless loop. In the Logfile from samba I see the following entry in a loop also "put name [FRONTEND] from [frontend] into dir struct"

BR
Christian

[2013/12/20 20:38:30.196883, 8] ../source3/smbd/dosmode.c:698(dos_mode)
dos_mode: ./frontend
[2013/12/20 20:38:30.196921, 8] ../source3/smbd/dosmode.c:237(dos_mode_from_sbuf)
dos_mode_from_sbuf returning d
[2013/12/20 20:38:30.196956, 8] ../source3/smbd/dosmode.c:31(dos_mode_debug_print)
dos_mode returning d
[2013/12/20 20:38:30.196999, 3] ../source3/smbd/dir.c:1134(smbd_dirptr_get_entry)
smbd_dirptr_get_entry mask=[????????.???] found ./frontend fname=frontend (frontend)
[2013/12/20 20:38:30.197042, 8] ../source3/smbd/dir.c:123(make_dir_struct)
put name [FRONTEND] from [frontend] into dir struct
[2013/12/20 20:38:30.197077, 6] ../source3/smbd/dir.c:913(dptr_fill)
fill on key 2 dirptr 0x7fa8c90972a0 now at -620357536
[2013/12/20 20:38:30.197112, 4] ../source3/smbd/reply.c:1799(reply_search)
SMBsearch mask=????????.??? path=. dtype=22 nument=1 of 1
[2013/12/20 20:38:30.197147, 5] ../source3/lib/util.c:168(show_msg)
[2013/12/20 20:38:30.197168, 5] ../source3/lib/util.c:178(show_msg)
size=83
smb_com=0x81
smb_rcls=0
smb_reh=0
smb_err=0
smb_flg=128
smb_flg2=2
smb_tid=25218
smb_pid=1467
smb_uid=22320
smb_mid=0
smt_wct=1
smb_vwv[ 0]= 1 (0x1)
smb_bcc=46
[2013/12/20 20:38:30.200091, 6] ../source3/smbd/process.c:1793(process_smb)
got message type 0x0 of len 0x41
[2013/12/20 20:38:30.200156, 3] ../source3/smbd/process.c:1795(process_smb)
Transaction 8 of length 69 (0 toread)
[2013/12/20 20:38:30.200181, 5] ../source3/lib/util.c:168(show_msg)
[2013/12/20 20:38:30.200191, 5] ../source3/lib/util.c:178(show_msg)
size=65
smb_com=0x81
smb_rcls=0
smb_reh=0
smb_err=0
smb_flg=0
smb_flg2=0
smb_tid=25218
smb_pid=1467
smb_uid=22320
smb_mid=0
smt_wct=2
smb_vwv[ 0]= 1 (0x1)
smb_vwv[ 1]= 46 (0x2E)
smb_bcc=26
[2013/12/20 20:38:30.200443, 3] ../source3/smbd/process.c:1398(switch_message)
switch message SMBsearch (pid 25114) conn 0x7fa8c909bb40
[2013/12/20 20:38:30.200493, 4] ../source3/smbd/uid.c:384(change_to_user)
Skipping user change - already user
[2013/12/20 20:38:30.200553, 3] ../source3/smbd/dir.c:944(dptr_fetch)
fetching dirptr 2 for path . at offset -620357536
[2013/12/20 20:38:30.200601, 4] ../source3/smbd/reply.c:1674(reply_search)
dptr_num is 2
[2013/12/20 20:38:30.200643, 8] ../source3/smbd/reply.c:1708(reply_search)
dirpath=<.> dontdescend=<>
[2013/12/20 20:38:30.200720, 6] ../source3/smbd/dir.c:1051(smbd_dirptr_get_entry)
smbd_dirptr_get_entry: dirptr 0x7fa8c909c3d0 now at offset 478943648076404832
[2013/12/20 20:38:30.200774, 8] ../source3/smbd/dosmode.c:698(dos_mode)
dos_mode: ./frontend
[2013/12/20 20:38:30.200819, 8] ../source3/smbd/dosmode.c:237(dos_mode_from_sbuf)
dos_mode_from_sbuf returning d
[2013/12/20 20:38:30.200861, 8] ../source3/smbd/dosmode.c:31(dos_mode_debug_print)
dos_mode returning d
[2013/12/20 20:38:30.200911, 3] ../source3/smbd/dir.c:1134(smbd_dirptr_get_entry)
smbd_dirptr_get_entry mask=[????????.???] found ./frontend fname=frontend (frontend)
[2013/12/20 20:38:30.200961, 8] ../source3/smbd/dir.c:123(make_dir_struct)
put name [FRONTEND] from [frontend] into dir struct
[2013/12/20 20:38:30.201004, 6] ../source3/smbd/dir.c:913(dptr_fill)
fill on key 2 dirptr 0x7fa8c90972a0 now at -620357536
[2013/12/20 20:38:30.201046, 4] ../source3/smbd/reply.c:1799(reply_search)
SMBsearch mask=????????.??? path=. dtype=22 nument=1 of 1
[2013/12/20 20:38:30.201089, 5] ../source3/lib/util.c:168(show_msg)
[2013/12/20 20:38:30.201114, 5] ../source3/lib/util.c:178(show_msg)
size=83
smb_com=0x81
smb_rcls=0
smb_reh=0
smb_err=0
smb_flg=128
smb_flg2=2
smb_tid=25218
smb_pid=1467
smb_uid=22320
smb_mid=0
smt_wct=1
smb_vwv[ 0]= 1 (0x1)
smb_bcc=46
[2013/12/20 20:38:30.204089, 6] ../source3/smbd/process.c:1793(process_smb)
got message type 0x0 of len 0x41
[2013/12/20 20:38:30.204167, 3] ../source3/smbd/process.c:1795(process_smb)
Transaction 9 of length 69 (0 toread)
[2013/12/20 20:38:30.204228, 5] ../source3/lib/util.c:168(show_msg)
[2013/12/20 20:38:30.204252, 5] ../source3/lib/util.c:178(show_msg)
size=65
smb_com=0x81
smb_rcls=0
smb_reh=0
smb_err=0
smb_flg=0
smb_flg2=0
smb_tid=25218
smb_pid=1467
smb_uid=22320
smb_mid=0
smt_wct=2
smb_vwv[ 0]= 1 (0x1)
smb_vwv[ 1]= 46 (0x2E)
smb_bcc=26
[2013/12/20 20:38:30.204451, 3] ../source3/smbd/process.c:1398(switch_message)
switch message SMBsearch (pid 25114) conn 0x7fa8c909bb40
[2013/12/20 20:38:30.204489, 4] ../source3/smbd/uid.c:384(change_to_user)
Skipping user change - already user
[2013/12/20 20:38:30.204534, 3] ../source3/smbd/dir.c:944(dptr_fetch)
fetching dirptr 2 for path . at offset -620357536
[2013/12/20 20:38:30.204572, 4] ../source3/smbd/reply.c:1674(reply_search)
dptr_num is 2
[2013/12/20 20:38:30.204605, 8] ../source3/smbd/reply.c:1708(reply_search)
dirpath=<.> dontdescend=<>
[2013/12/20 20:38:30.204669, 6] ../source3/smbd/dir.c:1051(smbd_dirptr_get_entry)
smbd_dirptr_get_entry: dirptr 0x7fa8c909c3d0 now at offset 478943648076404832
[2013/12/20 20:38:30.204713, 8] ../source3/smbd/dosmode.c:698(dos_mode)
dos_mode: ./frontend
[2013/12/20 20:38:30.204750, 8] ../source3/smbd/dosmode.c:237(dos_mode_from_sbuf)
dos_mode_from_sbuf returning d
[2013/12/20 20:38:30.204785, 8] ../source3/smbd/dosmode.c:31(dos_mode_debug_print)
dos_mode returning d
[2013/12/20 20:38:30.204826, 3] ../source3/smbd/dir.c:1134(smbd_dirptr_get_entry)
smbd_dirptr_get_entry mask=[????????.???] found ./frontend fname=frontend (frontend)
[2013/12/20 20:38:30.204868, 8] ../source3/smbd/dir.c:123(make_dir_struct)
put name [FRONTEND] from [frontend] into dir struct
Comment 1 Jeremy Allison 2014-01-08 01:21:45 UTC
This is the 32 vs 64 bit directory cookie issue. Known problem on a 64-bit machine. I'll mark this one as a duplicate once I find the right bug.

Jeremy.
Comment 2 Guenter Kukkukk 2014-01-10 03:07:25 UTC

*** This bug has been marked as a duplicate of bug 2662 ***