Bug 10339 - At shares "create" is missing, when I click a box -> blank screen
At shares "create" is missing, when I click a box -> blank screen
Status: RESOLVED DUPLICATE of bug 8999
Product: Samba 3.6
Classification: Unclassified
Component: SWAT
3.6.3
x86 All
: P5 normal
: ---
Assigned To: Kai Blin
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-20 10:07 UTC by Kiss, András
Modified: 2014-05-13 09:42 UTC (History)
0 users

See Also:


Attachments
Print screen (50.29 KB, image/jpeg)
2014-01-07 22:43 UTC, Kiss, András
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kiss, András 2013-12-20 10:07:21 UTC
I have checked all described in the "How to Install and Configure SWAT In Ubuntu Server 12.04" but it seems SWAT can't handling the cfg information. At the shares the "create" is missing, at the globals the base options are missing and when I want to switch to advanced the screen will be empty, only the title "samba" will be displayed. (But SAMBA is working properly ...) At the install - Normal installation, 12.04.3 server, x86 - Only SAMBA selected - After restart: sudo apt-get install swat xinetd

I have received the log messages as follows:

[2013/12/17 14:49:25.186512, 0] auth/pampass.c:827(smb_pam_passcheck) smb_pam_passcheck: PAM: smb_pam_auth failed - Rejecting User root ! [2013/12/17 14:49:45.018207, 0] lib/fault.c:47(fault_report) =============================================================== [2013/12/17 14:49:45.018328, 0] lib/fault.c:48(fault_report) INTERNAL ERROR: Signal 11 in pid 3469 (3.6.3) Please read the Trouble-Shooting section of the Samba3-HOWTO [2013/12/17 14:49:45.018409, 0] lib/fault.c:50(fault_report) e.t.c.

When I type in the command line the
sudo swat --configfile=/etc/samba/smb.conf

and close with enter not execute the command only begins a new line.
I can only finish with ctrl/Z or ctrl/C.

Thank you for help in advance. András
Comment 1 Kiss, András 2014-01-07 22:13:41 UTC
Reproduction of the symptom:
New installation with UBUNTU 12.04.3 x86 32 bit server.
Choose during install the SAMBA option, so after restart
smbd & nmbd are running.
After install
sudo apt-get install swat smbdfs xinetd
sudo update-inetd --enable 'swat'
sudo dpkg-reconfigure xinetd

Generate the swat file: /etc/xinetd.d/swat
service swat
{
port = 901
socket_type = stream
wait = no
user = root
server = /usr/sbin/swat
log_on_failure += USERID
disable = no
}
/* I have made it with mc because sudo cat > /etc/xinetd.d/swat <<-EOF
/* is not working due permission problem.

sudo chmod g+w /etc/samba/smb.conf
sudo chgrp adm /etc/samba/smb.conf
sudo service xinetd restart

I hope you can reproduce the symptom.
Comment 2 Kiss, András 2014-01-07 22:43:18 UTC
Created attachment 9558 [details]
Print screen
Comment 3 Kiss, András 2014-01-07 22:58:37 UTC
Same as bug 8999
Comment 4 Björn Jacke 2014-05-13 09:42:47 UTC

*** This bug has been marked as a duplicate of bug 8999 ***