Bug 10296 - SMB2 protocol SMB2_10 or above causes Windows Backup to fail
SMB2 protocol SMB2_10 or above causes Windows Backup to fail
Status: RESOLVED DUPLICATE of bug 10159
Product: Samba 4.0
Classification: Unclassified
Component: File services
All All
: P5 normal
: ---
Assigned To: Samba QA Contact
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2013-11-28 05:35 UTC by Jason
Modified: 2013-11-28 05:51 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Jason 2013-11-28 05:35:23 UTC
I regularly backup my Windows (7, 8, 8.1) machines to a Samba share.  After an upgrade to 4.0.12 (from 3.6.x), the backups started failing.  I downgraded the server and sure enough they started working again.  

Through trial and error I found that setting 'server max protocol = SMB2_02' allows the backups to run against Samba 4.  SMB2_10 or high causes a failure.

To reproduce, from a Windows box, run:

'wbadmin start backup -backupTarget:\\servername\share -allCritical'

With SMB2_10 or high, it will fail before reaching 1% after system image creation starts.

I have repeated this failure on 2x Debian Unstable servers.  Client logs (on both sides) show no meaningful errors.
Comment 1 Jason 2013-11-28 05:51:20 UTC
Just found this is a duplicate of https://bugzilla.samba.org/show_bug.cgi?id=10159

It may be nice to default the protocol to SMB2_02 in 4.x until this is resolved?  I lost half a day trying to solve this, the root cause being an incompletely implemented protocol and not enough messaging on client nor server.
Comment 2 Jason 2013-11-28 05:51:40 UTC

*** This bug has been marked as a duplicate of bug 10159 ***