Bug 1024 - smbclient tar get stuck if run over the midnight (00:00)
smbclient tar get stuck if run over the midnight (00:00)
Product: Samba 3.0
Classification: Unclassified
Component: smbclient
Other Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
Depends on:
  Show dependency treegraph
Reported: 2004-02-01 06:38 UTC by Gregor
Modified: 2005-02-07 10:12 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Gregor 2004-02-01 06:38:44 UTC
If I run smbclient in tar mode and it is run over the midnight (00:00 = 24:00)
the client get stuck. There is no error, just it stalls forever.
If I run the same job a minute after the midnight, the job runs fine.

We use this functionality under amanda backup, so it is critical to get proper
Comment 1 Gerald (Jerry) Carter 2004-03-12 07:08:53 UTC
please provide some means of identifying where 
smbclient is stalled at.  Debug logs, strace, network 
trace, etc...  Thanks.
Comment 2 Gregor 2004-03-17 08:11:04 UTC
It was the switch that caused this. Now it works fine.
Comment 3 Gerald (Jerry) Carter 2004-03-17 09:07:27 UTC
Kewl.  Thanks for the update.  Closing this bug.
Comment 4 Gregor 2004-04-07 22:46:03 UTC
Sorry for the update, but the problem remains. When we changed the switch, it 
was only faster and the copy procedure was finishing BEFORE midnight. This is 
why we didnt experience the problem, but now when data size is larger, and goes 
trough midnight, we have the problem, again. This happens exactly at 00:00!
smbclient just stops pulling data from win2k server, no errors, no nothing.
Comment 5 Gerald (Jerry) Carter 2004-04-09 06:50:26 UTC
I still need more information.  level 10 debug logs, a 
script to reproduce this, etc...
Comment 6 Gerald (Jerry) Carter 2005-02-07 10:12:01 UTC
no feedback in several months.