Bug 10239 - log.nmbd never rotates
log.nmbd never rotates
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Other
4.1.0
All All
: P5 regression
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 22:54 UTC by Thomas Bork
Modified: 2014-05-19 08:59 UTC (History)
2 users (show)

See Also:


Attachments
fix for 4.0, cherry-picked from master (1.24 KB, patch)
2014-03-27 10:47 UTC, Björn Baumbach
jra: review+
abartlet: review+
Details
fix for 4.1, cherry-picked from master (1.24 KB, patch)
2014-03-27 10:48 UTC, Björn Baumbach
jra: review+
abartlet: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Bork 2013-10-30 22:54:53 UTC
Since using Samba 4.1.0 the log file /var/log/log.nmbd never rotates. I'm using the internal rotate function of Samba. I have following definition in /etc/smb.conf:

max log size = 10000

The log /var/log/log.smbd rotates if nearly reaching 10 MB, but /var/log/log.nmbd is growing and never rotating to /var/log/log.nmbd.old.

referencetest26 # du -h /var/log/log.?mbd*
12M     /var/log/log.nmbd
8.7M    /var/log/log.smbd
9.8M    /var/log/log.smbd.old

This must be a regression to older Samba releases.
Comment 1 Björn Baumbach 2014-03-27 10:47:29 UTC
Created attachment 9812 [details]
fix for 4.0, cherry-picked from master
Comment 2 Björn Baumbach 2014-03-27 10:48:13 UTC
Created attachment 9813 [details]
fix for 4.1, cherry-picked from master
Comment 3 Andrew Bartlett 2014-03-28 07:13:41 UTC
Comment on attachment 9812 [details]
fix for 4.0, cherry-picked from master

Jeremy,

Can you also give your review on this and then assign to KS?

Thanks,
Comment 4 Jeremy Allison 2014-03-28 17:38:40 UTC
Re-assigning to Karolin for inclusion in 4.1.next, 4.0.next.
Jeremy.
Comment 5 Thomas Bork 2014-04-04 20:23:14 UTC
Too late for 4.1.7?
Comment 6 Karolin Seeger 2014-04-07 08:01:24 UTC
(In reply to comment #5)
> Too late for 4.1.7?

Unfortunately, yes. Will be included in the next bug fix releases.
Comment 7 Karolin Seeger 2014-04-29 08:15:51 UTC
Pushed to autobuild-v4-0-test and autobuild-v4-1-test.
Comment 8 Karolin Seeger 2014-05-19 08:59:24 UTC
(In reply to comment #7)
> Pushed to autobuild-v4-0-test and autobuild-v4-1-test.

Pushed to both branches.
Closing out bug report.

Thanks!