Bug 1023 - Failed to open group mapping database
Failed to open group mapping database
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control
3.0.2a
All Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
http://www.mail-archive.com/samba@lis...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-01 01:09 UTC by Benjamin Coles
Modified: 2005-11-14 09:28 UTC (History)
0 users

See Also:


Attachments
Log Level 10 of the the issue (13.83 KB, text/plain)
2004-02-08 20:27 UTC, Benjamin Coles
no flags Details
Log of default configuration as requested (1.95 KB, text/plain)
2004-02-11 08:17 UTC, Benjamin Coles
no flags Details
patch for get_alias_user_groups() (635 bytes, patch)
2004-04-01 07:13 UTC, Gerald (Jerry) Carter
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Coles 2004-02-01 01:09:15 UTC
I've been following this bug closely but nothings been done since my mention of 
it during the upgrade path to 3.0. The following also only happens when a user 
logs out of the computer.

Problem:
Failed to open group mapping database

Solution to this problem:
"chmod 666 group_mapping.tdb" 

this fixes the problem but creates another with LDAP saying not enough access:
ldapsam_search_one_group: Problem during the LDAP search: LDAP error:
  (Insufficient access) 

In which there is no solution at the present time... or I haven't found one. 
I've also got a "User has an invalid RID this should be fixed error" but I 
think it's related to the above error since the above error does mappings. 
Thanks in advance=)
Comment 1 Benjamin Coles 2004-02-08 20:27:06 UTC
Created attachment 391 [details]
Log Level 10 of the the issue

This is the problem in debug level 10
Comment 2 Gerald (Jerry) Carter 2004-02-10 20:08:09 UTC
there's no 'failed to open group...' error in your log.
I need more defaults on how to reproduce this and possibly 
a level 10 debug log.
Comment 3 Benjamin Coles 2004-02-11 08:17:19 UTC
Created attachment 395 [details]
Log of default configuration as requested

This log file has the /var/cache/samba/group_mapping.tdb chmoded 600 where the
last one had it 666. Also in both cases Administrator is able to login and
errors don't show up but when you login with a Power User or Domain User it
spits out those errors.
Comment 4 Gerald (Jerry) Carter 2004-03-31 13:56:50 UTC
need to surround get_group_from_gid() (called 
from  get_alias_user_groups()) in a become_root() block.
Comment 5 Gerald (Jerry) Carter 2004-04-01 07:13:50 UTC
Created attachment 463 [details]
patch for get_alias_user_groups()

surround get_group_from_gid() in become_unbecome_root() block.
Comment 6 Gerald (Jerry) Carter 2004-04-01 07:15:41 UTC
changes applied to 3.0 and HEAD cvs branches.
Comment 7 Gerald (Jerry) Carter 2005-02-07 07:39:52 UTC
originally reported against 3.0.3pre1.  Moving back to version to 3.0.2a
to remove preX and rcX versions.
Comment 8 Gerald (Jerry) Carter 2005-02-07 07:42:12 UTC
originally reported against 3.0.3pre2.  Moving back to version to 3.0.2a
to remove preX and rcX versions.
Comment 9 Gerald (Jerry) Carter 2005-08-24 10:24:05 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 10 Gerald (Jerry) Carter 2005-11-14 09:28:02 UTC
database cleanup