Bug 1018 - Group mapping - Net groupmap modify doesn't add the sambaGroupMapping objectClass
Group mapping - Net groupmap modify doesn't add the sambaGroupMapping objectC...
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.1
All Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
http://lists.samba.org/archive/samba-...
:
Depends on:
Blocks: 828
  Show dependency treegraph
 
Reported: 2004-01-30 01:37 UTC by Ganael LAPLANCHE
Modified: 2005-02-05 07:42 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ganael LAPLANCHE 2004-01-30 01:37:17 UTC
ldapsam_update_group_mapping_entry doesn't add the sambaGroupMapping
objectClass when MODIFYING a mapping that involves a "simple" posixGroup
entry in LDAP, like this one :

dn: cn=myusers,ou=Users,dc=mydomain,dc=com
objectClass: posixGroup
gidNumber: 1012
cn: myusers
memberUid: foouser

The result is the mapping can't be modified, here is the error :

ldapsam_update_group_mapping_entry: failed to modify group 1012 error:
attribute 'sambaSID' not allowed (Object class violation)
Could not update group database

We don't get this error when we CREATE a mapping because the objectClass is
automatically added.
Comment 1 Gerald (Jerry) Carter 2004-01-30 05:50:31 UTC
This is by design.  You don't have a group mapping 
with out the sambaGroupMapping objectClass so you 
create one (net groupmap add).  Why do you consider 
this a bug?
Comment 2 Ganael LAPLANCHE 2004-01-30 06:18:44 UTC
You're right, but the purpose of the net groupmap modify command is to assign a
gid to a SID already mapped *on the fly*. It means the new gid may (or may not)
be already used in another mapping, so may or may not contain any mapping info.
In my opinion this is to be verified :

if new gid already used (contains mapping info) -> can't be re-mapped without
deletion of the old entry.

if not -> Ok, but doesn't contain mapping info, we should add the correct
objectClass / info needed.
Comment 3 Gerald (Jerry) Carter 2004-02-10 20:39:24 UTC
patches are welcome.
Comment 4 Gerald (Jerry) Carter 2005-02-05 07:42:15 UTC
no response from reporter.