Bug 10120 - DNS server fails on some TXT queries
DNS server fails on some TXT queries
Status: RESOLVED WORKSFORME
Product: Samba 4.0
Classification: Unclassified
Component: DNS server
4.0.9
x64 Linux
: P5 normal
: ---
Assigned To: Kai Blin
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 13:07 UTC by IT2
Modified: 2014-05-19 06:36 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description IT2 2013-08-28 13:07:53 UTC
We use a dns forwarder for dns resolving and the internal samba4 dns server, but unfortunately it does not resolve all RRs:

root@linsrv:~# dig txt gfp.at

; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> txt gfp.at
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 61896
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;gfp.at.                                IN      TXT

;; Query time: 1 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Wed Aug 28 15:07:56 2013
;; MSG SIZE  rcvd: 24

The RR exist:

root@linsrv:~# dig txt gfp.at @172.16.0.127

; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> txt gfp.at @172.16.0.127
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 17186
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;gfp.at.                                IN      TXT

;; ANSWER SECTION:
gfp.at.                 2177    IN      TXT     "gfp.at" "MS=ms42353263"

;; Query time: 0 msec
;; SERVER: 172.16.0.127#53(172.16.0.127)
;; WHEN: Wed Aug 28 15:08:14 2013
;; MSG SIZE  rcvd: 57


MX-RR gets resolved:

root@linsrv:~# dig mx gfp.at

; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> mx gfp.at
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 56387
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 2

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1280
;; QUESTION SECTION:
;gfp.at.                                IN      MX

;; ANSWER SECTION:
gfp.at.                 900     IN      MX      10 mail.casariso.com.

;; ADDITIONAL SECTION:
mail.casariso.com.      6545    IN      A       194.50.173.12

;; Query time: 66 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Wed Aug 28 15:08:33 2013
;; MSG SIZE  rcvd: 84



see: https://bugzilla.samba.org/show_bug.cgi?id=9485
Comment 1 Kai Blin 2013-08-28 13:12:15 UTC
Hi. Never mind the recursion warning, that's an artifact of the server handling server errors, the "status: SERVFAIL" is what's causing your problem.

To figure out why the server is failing, I would need the debug output from the failing query, ideally with debug level = dns:10

Thanks,
Kai
Comment 2 IT2 2013-08-29 14:17:28 UTC
Hi Kai,

I tried it once befor setting the debug level:

root@linsrv:~# dig txt gfp.at

; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> txt gfp.at
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 17560
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;gfp.at.                                IN      TXT

;; Query time: 2002 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Thu Aug 29 16:14:31 2013
;; MSG SIZE  rcvd: 24


After setting

  debug level = dns:10
  log file = /var/log/samba/debug.log

and "samba-tool testparm" and "/etc/init.d/samba4 restart" the log stays empty, but the dig did:

root@linsrv:~# dig txt gfp.at

; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> txt gfp.at
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 9417
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1280
;; QUESTION SECTION:
;gfp.at.                                IN      TXT

;; ANSWER SECTION:
gfp.at.                 3431    IN      TXT     "MS=ms42353263"

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Thu Aug 29 16:17:18 2013
;; MSG SIZE  rcvd: 61


Don't understand...
Comment 3 Kai Blin 2014-05-19 06:36:42 UTC
Can't reproduce, closing. Please re-open if this still fails for you and you can provide the requested log files.