Bug 1012 - smbd doesn't return server names if user login as ordinary user
smbd doesn't return server names if user login as ordinary user
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.2
All Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-27 23:57 UTC by SATOH Fumiyasu
Modified: 2005-09-27 12:26 UTC (History)
1 user (show)

See Also:


Attachments
smb.conf (135 bytes, text/plain)
2004-01-27 23:58 UTC, SATOH Fumiyasu
no flags Details
log.smbd (smbclient -L127.0.0.1 -U%) (86.23 KB, text/plain)
2004-01-28 00:02 UTC, SATOH Fumiyasu
no flags Details
log.smbd (smbclient -L127.0.0 -Uvaliduser%validpass) (102.13 KB, text/plain)
2004-01-28 00:03 UTC, SATOH Fumiyasu
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description SATOH Fumiyasu 2004-01-27 23:57:28 UTC
If I use smbclinet -L with guest user, smbd returns correct answer:
$ smbclient -L127.0.0.1 -U% |sed -n '/Server/,/Workgroup/p'
        Server               Comment
        ---------            -------
        TESTNBN              Samba 3.0.1

        Workgroup            Master

But I use smbclient -L with valid user%pass, smbd does NOT return
server list:
$ smbclient -L127.0.0.1 -Ufumiya%foo |sed -n '/Server/,/Workgroup/p'
        Server               Comment
        ---------            -------

        Workgroup            Master
Comment 1 SATOH Fumiyasu 2004-01-27 23:58:59 UTC
Created attachment 369 [details]
smb.conf
Comment 2 SATOH Fumiyasu 2004-01-28 00:02:03 UTC
Created attachment 370 [details]
log.smbd (smbclient -L127.0.0.1 -U%)
Comment 3 SATOH Fumiyasu 2004-01-28 00:03:15 UTC
Created attachment 371 [details]
log.smbd (smbclient -L127.0.0 -Uvaliduser%validpass)
Comment 4 SATOH Fumiyasu 2004-01-28 00:18:18 UTC
I've tested smbclient -L against Windows NT Server 4.0 SP6a. 
Windows returns server list in both cases.
Comment 5 Gerald (Jerry) Carter 2004-02-11 07:18:26 UTC
I've tested this against 3.0.2 using ports 139 and 445.  
The server is returned in all cases.  Marking this as fixed.  
Please reopen if you can reproduce this against 3.0.2


smbclient -L queso -Ufoo%bar -WVALE 
Domain=[VALE] OS=[Unix] Server=[Samba 3.0.2]

        Sharename      Type      Comment
        ---------      ----      -------
.....
        Server               Comment
        ---------            -------
        OPENSRV              Samba 3.0.2
        QUESO                Samba 3.0.2
        VELMA                Samba 3.0.2
        XERA

        Workgroup            Master
        ---------            -------
        AD                   SPUD
        AQUA                 BLUE
        COLOR                PRIMARY
...
Comment 6 SATOH Fumiyasu 2004-02-12 00:38:10 UTC
Reproduced.

$ smbclient -L sugar -Ufoo%bar

	Sharename      Type      Comment
	---------      ----      -------
	IPC$           IPC       IPC Service (Samba 3.0.2)
	ADMIN$         IPC       IPC Service (Samba 3.0.2)

	Server               Comment
	---------            -------

	Workgroup            Master
	---------            -------
	TESTWG               

$ smbclient -L sugar -U%

	Sharename      Type      Comment
	---------      ----      -------
	IPC$           IPC       IPC Service (Samba 3.0.2)
	ADMIN$         IPC       IPC Service (Samba 3.0.2)

	Server               Comment
	---------            -------
	SUGAR                Samba 3.0.2

	Workgroup            Master
	---------            -------
	TESTWG               

My smb.conf:
[global]
    workgroup = TESTWG
    ## netbios name = TESTNBN

    passdb backend = tdbsam
    encrypt passwords = yes
Comment 7 SATOH Fumiyasu 2004-02-12 00:48:22 UTC
Hmmm. With smbclient 2.2.8a against Samba server 3.0.2, it seems no problem.

$ /usr/local/samba-2.2.8a-ja-1.1/bin/smbclient -L sugar -Ufoo%foo
added interface ip=10.0.255.1 bcast=10.0.255.255 nmask=255.255.255.0
added interface ip=192.168.200.100 bcast=192.168.200.255 nmask=255.255.255.0
added interface ip=127.0.0.2 bcast=127.255.255.255 nmask=255.0.0.0
added interface ip=10.255.255.1 bcast=10.255.255.255 nmask=255.255.255.0
Domain=[TESTWG] OS=[Unix] Server=[Samba 3.0.2]

	Sharename      Type      Comment
	---------      ----      -------
	IPC$           IPC       IPC Service (Samba 3.0.2)
	ADMIN$         IPC       IPC Service (Samba 3.0.2)

	Server               Comment
	---------            -------
	SUGAR                Samba 3.0.2

	Workgroup            Master
	---------            -------
	TESTWG               SUGAR
Comment 8 Gerald (Jerry) Carter 2005-09-27 12:26:49 UTC
Seems to be working fine now (r10551).